build: fix git prereq check to forcibly disable man pagers on the --help check
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Mar 2016 13:37:02 +0000 (13:37 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Mar 2016 13:37:02 +0000 (13:37 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48927 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index 443b173..a93dd63 100644 (file)
@@ -155,7 +155,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       git submodule --help 2>&1 | grep -q -- --recursive))
+       MANPAGER=cat git submodule --help 2>&1 | grep -q -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))