ramips: fix Buffalo WMR-300 dts, board, image and profile names
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 06:00:49 +0000 (06:00 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 06:00:49 +0000 (06:00 +0000)
The following patch changes Buffalo WMR-300 dts filename, board, image and profile names from "WMR300" to "WMR-300" (for consistency).

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46628 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WMR-300.dts [new file with mode: 0644]
target/linux/ramips/dts/WMR300.dts [deleted file]
target/linux/ramips/image/Makefile

index 0fab232..334003d 100755 (executable)
@@ -77,7 +77,7 @@ ramips_setup_interfaces()
 
        wizard8800 | \
        wl-330n | \
-       wmr300)
+       wmr-300)
                ucidef_set_interface_lan "eth0.1"
                ;;
 
index e7499a8..c8014bf 100644 (file)
@@ -183,8 +183,8 @@ get_status_led() {
        whr-g300n)
                status_led="whr-g300n:green:router"
                ;;
-       wmr300)
-               status_led="buffalo:green:status"
+       wmr-300)
+               status_led="wmr-300:green:status"
                ;;
        wli-tx4-ag300n)
                status_led="buffalo:blue:power"
index 9b37ce6..98bd094 100755 (executable)
@@ -320,7 +320,7 @@ ramips_board_detect() {
                name="w502u"
                ;;
        *"WMR-300")
-               name="wmr300"
+               name="wmr-300"
                ;;
        *"WHR-300HP2")
                name="whr-300hp2"
index 7249005..e347d6f 100755 (executable)
@@ -112,7 +112,7 @@ platform_check_image() {
        wl-341v3 | \
        wli-tx4-ag300n | \
        wzr-agl300nh | \
-       wmr300 |\
+       wmr-300 |\
        wnce2001 | \
        wr512-3gn |\
        wr6202 |\
diff --git a/target/linux/ramips/dts/WMR-300.dts b/target/linux/ramips/dts/WMR-300.dts
new file mode 100644 (file)
index 0000000..3dae3ae
--- /dev/null
@@ -0,0 +1,106 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "buffalo,wmr-300", "ralink,mt7620n-soc";
+       model = "Buffalo WMR-300";
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l6405d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "wllll";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               ralink,group = "i2c", "ephy";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               aoss1 {
+                       label = "wmr-300:red:aoss";
+                       gpios = <&gpio2 1 1>;
+               };
+
+               aoss2 {
+                       label = "wmr-300:green:aoss";
+                       gpios = <&gpio2 2 1>;
+               };
+
+               power {
+                       label = "wmr-300:green:status";
+                       gpios = <&gpio2 4 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+
+               aoss {
+                       label = "aoss";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x211>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/WMR300.dts b/target/linux/ramips/dts/WMR300.dts
deleted file mode 100644 (file)
index fbeec4c..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-/dts-v1/;
-
-/include/ "mt7620n.dtsi"
-
-/ {
-       compatible = "buffalo,wmr-300", "ralink,mt7620n-soc";
-       model = "Buffalo WMR-300";
-
-       palmbus@10000000 {
-               gpio2: gpio@660 {
-                       status = "okay";
-               };
-
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "mx25l6405d";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "en25q64";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x7b0000>;
-                               };
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-               ralink,port-map = "wllll";
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       default {
-                               ralink,group = "i2c", "ephy";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               aoss1 {
-                       label = "buffalo:red:aoss";
-                       gpios = <&gpio2 1 1>;
-               };
-
-               aoss2 {
-                       label = "buffalo:green:aoss";
-                       gpios = <&gpio2 2 1>;
-               };
-
-               power {
-                       label = "buffalo:green:status";
-                       gpios = <&gpio2 4 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 1 1>;
-                       linux,code = <0x198>;
-               };
-
-               aoss {
-                       label = "aoss";
-                       gpios = <&gpio0 2 1>;
-                       linux,code = <0x211>;
-               };
-       };
-};
index f3f40eb..2539b5a 100644 (file)
@@ -874,7 +874,7 @@ Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),y1,Y1)
 Image/Build/Profile/Y1S=$(call BuildFirmware/Default16M/$(1),$(1),y1s,Y1S)
 Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW221)
 Image/Build/Profile/MLWG2=$(call BuildFirmware/Default16M/$(1),$(1),mlwg2,MLWG2)
-Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
+Image/Build/Profile/WMR-300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR-300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
 Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
 Image/Build/Profile/WT3020=$(call BuildFirmware/PorayDualSize/$(1),$(1),wt3020,WT3020)
@@ -908,7 +908,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/Y1S,$(1))
        $(call Image/Build/Profile/MLW221,$(1))
        $(call Image/Build/Profile/MLWG2,$(1))
-       $(call Image/Build/Profile/WMR300,$(1))
+       $(call Image/Build/Profile/WMR-300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
        $(call Image/Build/Profile/WRTNODE,$(1))
        $(call Image/Build/Profile/WT3020,$(1))