ar71xx: add sysupgrade support for wndr4300
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jun 2014 13:00:00 +0000 (13:00 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jun 2014 13:00:00 +0000 (13:00 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41131 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/image/Makefile

index a6723fa..4e698c6 100755 (executable)
@@ -305,6 +305,14 @@ platform_check_image() {
                }
                return 0
                ;;
+       wndr4300 )
+               nand_do_upgrade_stage1 $board $1
+               [ $? != 0 ] && {
+                       echo "Invalid tar file."
+                       return 1
+               }
+               return 0;
+               ;;
        routerstation | \
        routerstation-pro | \
        ls-sr71 | \
index 924ec66..d0ee363 100644 (file)
@@ -877,6 +877,8 @@ define Image/Build/NetgearNAND
                -B $(6) -v OpenWrt.$(REVISION) -r "$$$$r" $(8) \
                -i $(imageraw) \
                -o $(call imgname,ubi,$(2))-factory.img
+
+       $(call Image/Build/SysupgradeNAND,$(2),$(KDIR_TMP)/vmlinux-$(2).uImage,$(KDIR_TMP)/root.squashfs)
 endef