add a feature flag for device tree support
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Nov 2013 12:01:01 +0000 (12:01 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Nov 2013 12:01:01 +0000 (12:01 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38893 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
include/target.mk
scripts/metadata.pl
target/Config.in

index bf1e139..5607e55 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -204,7 +204,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_INCLUDE_DTB
                bool "Include DTB in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
+               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
                default n if USES_UBIFS
                help
                  Include the device tree blob file(s) in the rootfs. Typically the DTBs
index 467ef35..acb9adf 100644 (file)
@@ -167,6 +167,9 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
+    ifneq ($(CONFIG_OF),)
+      FEATURES += dt
+    endif
     ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
       FEATURES += gpio
     endif
index ddcf50b..135ec9a 100755 (executable)
@@ -158,6 +158,7 @@ sub target_config_features(@) {
                /broken/ and $ret .= "\tdepends on BROKEN\n";
                /audio/ and $ret .= "\tselect AUDIO_SUPPORT\n";
                /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
+               /dt/ and $ret .= "\tselect USES_DEVICETREE\n";
                /gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
                /pcie/ and $ret .= "\tselect PCIE_SUPPORT\n";
index 7f694e4..bb44202 100644 (file)
@@ -39,6 +39,9 @@ config RTC_SUPPORT
 config BIG_ENDIAN
        bool
 
+config USES_DEVICETREE
+       bool
+
 config USES_INITRAMFS
        bool