ar71xx: use DEFAULT:= in the uboot-ar71xx package instead of adding uboot to the...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Apr 2011 12:43:21 +0000 (12:43 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Apr 2011 12:43:21 +0000 (12:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26401 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uboot-ar71xx/Makefile
target/linux/ar71xx/generic/profiles/00-default.mk
target/linux/ar71xx/generic/profiles/01-minimal.mk
target/linux/ar71xx/generic/profiles/zyxel.mk

index 86a20a8..fd97392 100644 (file)
@@ -39,6 +39,7 @@ define Package/uboot-ar71xx-$(1)
   DEPENDS:=@TARGET_ar71xx_generic_Default||TARGET_ar71xx_generic_Minimal||TARGET_ar71xx_generic_NBG_460N_550N_550NH
   TITLE:=$(2)
   URL:=http://www.denx.de/wiki/U-Boot
+  DEFAULT:=y if (TARGET_ar71xx_generic_NBG_460N_550N_550NH || TARGET_ar71xx_generic_Default || CONFIG_TARGET_ar71xx_generic_Minimal)
   VARIANT:=$(1)
 endef
 endef
index 99daf05..7166be5 100644 (file)
@@ -9,7 +9,7 @@ define Profile/Default
        NAME:=Default Profile (all drivers)
        PACKAGES:= \
                kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig \
-               wpad-mini uboot-ar71xx-nbg460n_550n_550nh kmod-ledtrig-usbdev
+               wpad-mini kmod-ledtrig-usbdev
 endef
 
 define Profile/Default/Description
index d92eb15..812ae6f 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Minimal
        NAME:=Minimal Profile (no drivers)
-       PACKAGES:=uboot-ar71xx-nbg460n_550n_550nh
+       PACKAGES:=
 endef
 
 define Profile/Minimal/Description
index 8004d15..b4da304 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/NBG_460N_550N_550NH
        NAME:=Zyxel NBG 460N/550N/550NH
-       PACKAGES:=kmod-ath9k kmod-rtc-pcf8563 swconfig uboot-ar71xx-nbg460n_550n_550nh
+       PACKAGES:=kmod-ath9k kmod-rtc-pcf8563 swconfig
 endef
 
 define Profile/NBG_460N_550N_550NH/Description