[sdk] make sure .config gets copied as file
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Jan 2012 03:30:30 +0000 (03:30 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Jan 2012 03:30:30 +0000 (03:30 +0000)
When using scripts/env, .config is most likely a symbolic link
pointing to env/.config. Previously the symbolic link got
copied as-is into the SDK tarball, leading to a dangling .config
symlink on the target system which prevented the SDK from working.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29927 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/sdk/Makefile

index bad5099..7374041 100644 (file)
@@ -40,7 +40,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        rm -rf \
                $(SDK_BUILD_DIR)/target/linux/*/files \
                $(SDK_BUILD_DIR)/target/linux/*/patches
-       $(CP) \
+       $(CP) -L \
                $(TOPDIR)/LICENSE \
                $(TOPDIR)/rules.mk \
                $(TOPDIR)/.config \