bluetooth fixes from Tomas Vanek
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Jul 2005 21:35:01 +0000 (21:35 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Jul 2005 21:35:01 +0000 (21:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1571 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/bluez-utils/Makefile
openwrt/package/bluez-utils/ipkg/bluez-utils.control
openwrt/package/bluez-utils/patches/001-include_limits.patch [new file with mode: 0644]
openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch [new file with mode: 0644]

index 40ab279..a31de26 100644 (file)
@@ -67,6 +67,7 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
+       rm -f $(PKG_INSTALL_DIR)/usr/bin/bluepin
        touch $@
 
 $(IPKG_BLUEZ_UTILS):
@@ -75,8 +76,9 @@ $(IPKG_BLUEZ_UTILS):
        install -d -m0755 $(IDIR_BLUEZ_UTILS)/usr/sbin
        cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/* $(IDIR_BLUEZ_UTILS)/usr/sbin/
        install -d -m0755 $(IDIR_BLUEZ_UTILS)/etc/bluetooth
-       cp -fp $(PKG_INSTALL_DIR)/../hcid/hcid.conf* $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
-       cp -fp $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf* $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
+       cp -fp $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
+       cp -fp $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
+       install -m0700 ./files/givepin $(IDIR_BLUEZ_UTILS)/etc/bluetooth/
 
        $(RSTRIP) $(IDIR_BLUEZ_UTILS)
        $(IPKG_BUILD) $(IDIR_BLUEZ_UTILS) $(PACKAGE_DIR)
index 7592cbf..3772653 100644 (file)
@@ -3,5 +3,5 @@ Priority: optional
 Section: net
 Maintainer: Markus Becker <mab@comnets.uni-bremen.de>
 Source: http://bluez.org
-Description: Bluez libs
+Description: Bluez utils
 Depends: kmod-bluetooth, bluez-libs
diff --git a/openwrt/package/bluez-utils/patches/001-include_limits.patch b/openwrt/package/bluez-utils/patches/001-include_limits.patch
new file mode 100644 (file)
index 0000000..6f6cb82
--- /dev/null
@@ -0,0 +1,22 @@
+diff -ur bluez-utils-2.17.orig/hidd/sdp.c bluez-utils-2.17/hidd/sdp.c
+--- bluez-utils-2.17.orig/hidd/sdp.c   2005-05-09 20:33:24.000000000 +0200
++++ bluez-utils-2.17/hidd/sdp.c        2005-07-26 14:38:13.000000000 +0200
+@@ -39,6 +39,7 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/socket.h>
++#include <linux/limits.h>
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/l2cap.h>
+diff -ur bluez-utils-2.17.orig/tools/hciconfig.c bluez-utils-2.17/tools/hciconfig.c
+--- bluez-utils-2.17.orig/tools/hciconfig.c    2005-05-09 20:33:24.000000000 +0200
++++ bluez-utils-2.17/tools/hciconfig.c 2005-07-26 14:34:29.000000000 +0200
+@@ -40,6 +40,7 @@
+ #include <getopt.h>
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
++#include <linux/limits.h>
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/hci.h>
diff --git a/openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch b/openwrt/package/bluez-utils/patches/002-hcid_pin_helper.patch
new file mode 100644 (file)
index 0000000..17a7f36
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ur bluez-utils-2.17.orig/hcid/hcid.conf bluez-utils-2.17/hcid/hcid.conf
+--- bluez-utils-2.17.orig/hcid/hcid.conf       2004-12-25 19:06:00.000000000 +0100
++++ bluez-utils-2.17/hcid/hcid.conf    2005-07-26 14:44:23.000000000 +0200
+@@ -23,7 +23,7 @@
+       pairing multi;
+       # PIN helper
+-      pin_helper /usr/bin/bluepin;
++      pin_helper /etc/bluetooth/givepin;
+       # D-Bus PIN helper
+       #dbus_pin_helper;
+@@ -34,7 +34,7 @@
+       # Local device name
+       #   %d - device id
+       #   %h - host name
+-      name "BlueZ (%d)";
++      name "OpenWRT";
+       # Local device class
+       class 0x3e0100;
index 0e4658c..00d4693 100644 (file)
@@ -78,6 +78,7 @@ $(eval $(call KMOD_template,B44,b44,\
 ,CONFIG_B44))
 $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
        $(MODULES_DIR)/kernel/net/bluetooth/*.o \
+       $(MODULES_DIR)/kernel/net/bluetooth/rfcomm/*.o \
        $(MODULES_DIR)/kernel/drivers/bluetooth/*.o \
 ,CONFIG_BLUEZ))
 $(eval $(call KMOD_template,ARPT,arptables,\
diff --git a/openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch b/openwrt/target/linux/linux-2.4/patches/brcm/005-bluetooth_sco_buffer_align.patch
new file mode 100644 (file)
index 0000000..77ade1c
--- /dev/null
@@ -0,0 +1,12 @@
+--- linux-2.4.30/drivers/bluetooth/hci_usb.c   2004-08-08 01:26:04.000000000 +0200
++++ linux-2.4.30/drivers/bluetooth/hci_usb.c   2005-07-25 20:12:11.000000000 +0200
+@@ -259,6 +259,9 @@
+       void *buf;
+       mtu  = husb->isoc_in_ep->wMaxPacketSize;
++#ifdef CONFIG_BCM4710
++      mtu = (mtu + 1) & ~1;           /* brcm: isoc buffers must be aligned on word boundary */
++#endif
+         size = mtu * HCI_MAX_ISOC_FRAMES;
+       buf = kmalloc(size, GFP_ATOMIC);