kernel: update 3.10 to 3.10.18
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Nov 2013 08:25:45 +0000 (08:25 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Nov 2013 08:25:45 +0000 (08:25 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38652 3c298f89-4303-0410-b956-a3cf2f4a3e73

42 files changed:
include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.10/655-increase_skb_pad.patch
target/linux/generic/patches-3.10/656-skb_reduce_truesize-helper.patch
target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.10/721-phy_packets.patch
target/linux/generic/patches-3.10/902-debloat_proc.patch
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/kirkwood/patches-3.10/0020-net-mv643xx_eth-use-phy_disconnect-instead-of-phy_de.patch
target/linux/kirkwood/patches-3.10/0021-net-mv643xx_eth-use-managed-devm_ioremap-for-port-re.patch
target/linux/kirkwood/patches-3.10/0023-net-mv643xx_eth-use-of_phy_connect-if-phy_node-prese.patch
target/linux/kirkwood/patches-3.10/0024-net-mv643xx_eth-proper-initialization-for-Kirkwood-S.patch
target/linux/kirkwood/patches-3.10/0025-net-mv643xx_eth-add-DT-parsing-support.patch
target/linux/kirkwood/patches-3.10/0029-net-mv643xx_eth-do-not-use-port-number-as-platform-d.patch
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.10/0100-mtd-split.patch
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/mxs/Makefile
target/linux/octeon/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.10/0122-pinmux.patch
target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/sunxi/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/xburst/Makefile

index b8ff3ce..91752e0 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.17)
-  LINUX_KERNEL_MD5SUM:=0c52d1266fe1087bcfa6517646188ecc
+ifeq ($(LINUX_VERSION),3.10.18)
+  LINUX_KERNEL_MD5SUM:=e091753da622788cfd662dd67c2f9b48
 endif
 
 # disable the md5sum check for unknown kernel versions
index 74321a2..ab0e694 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 8c7a1d6..2491bc6 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=mips16
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index ce55abd..1807dfb 100644 (file)
  #define IP_TTL                2
 --- a/net/core/secure_seq.c
 +++ b/net/core/secure_seq.c
-@@ -54,11 +54,12 @@ __u32 secure_tcpv6_sequence_number(const
+@@ -56,11 +56,12 @@ __u32 secure_tcpv6_sequence_number(const
        u32 secret[MD5_MESSAGE_BYTES / 4];
        u32 hash[MD5_DIGEST_WORDS];
        u32 i;
        secret[4] = net_secret[4] +
                (((__force u16)sport << 16) + (__force u16)dport);
        for (i = 5; i < MD5_MESSAGE_BYTES / 4; i++)
-@@ -76,11 +77,12 @@ u32 secure_ipv6_port_ephemeral(const __b
+@@ -78,11 +79,12 @@ u32 secure_ipv6_port_ephemeral(const __b
        u32 secret[MD5_MESSAGE_BYTES / 4];
        u32 hash[MD5_DIGEST_WORDS];
        u32 i;
        secret[4] = net_secret[4] + (__force u32)dport;
        for (i = 5; i < MD5_MESSAGE_BYTES / 4; i++)
                secret[i] = net_secret[i];
-@@ -183,11 +185,12 @@ u64 secure_dccpv6_sequence_number(__be32
+@@ -185,11 +187,12 @@ u64 secure_dccpv6_sequence_number(__be32
        u32 hash[MD5_DIGEST_WORDS];
        u64 seq;
        u32 i;
                tpi->seq = 0;
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3592,14 +3592,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3625,14 +3625,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index fad8292..c8be8bc 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index f1cd5a8..69ca530 100644 (file)
@@ -14,7 +14,7 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 57d5af6..6cc5cfb 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 09fd152..cf2b07a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
index 34b608b..b89de8b 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 0903272..9db7047 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 6e10a1a..590fa16 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -1848,7 +1848,7 @@ static inline int pskb_network_may_pull(
+@@ -1853,7 +1853,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 59cfa6a..86b7e1f 100644 (file)
@@ -14,7 +14,7 @@ when needed.
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -1893,6 +1893,24 @@ static inline void pskb_trim_unique(stru
+@@ -1898,6 +1898,24 @@ static inline void pskb_trim_unique(stru
        BUG_ON(err);
  }
  
index 556adcc..4614d8e 100644 (file)
  static const struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
-@@ -1481,6 +1499,9 @@ int ip6_route_add(struct fib6_config *cf
+@@ -1505,6 +1523,9 @@ int ip6_route_add(struct fib6_config *cf
                case RTN_THROW:
                        rt->dst.error = -EAGAIN;
                        break;
                default:
                        rt->dst.error = -ENETUNREACH;
                        break;
-@@ -2057,6 +2078,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2084,6 +2105,17 @@ static int ip6_pkt_prohibit_out(struct s
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
  #endif
  
  /*
-@@ -2262,7 +2294,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2290,7 +2322,8 @@ static int rtm_to_fib6_config(struct sk_
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -2464,6 +2497,9 @@ static int rt6_fill_node(struct net *net
+@@ -2492,6 +2525,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
-@@ -2714,6 +2750,8 @@ static int ip6_route_dev_notify(struct n
+@@ -2742,6 +2778,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -2974,6 +3012,17 @@ static int __net_init ip6_route_net_init
+@@ -3002,6 +3040,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -2992,6 +3041,8 @@ out:
+@@ -3020,6 +3069,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3009,6 +3060,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3037,6 +3088,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3105,6 +3157,9 @@ int __init ip6_route_init(void)
+@@ -3133,6 +3185,9 @@ int __init ip6_route_init(void)
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 8692007..f678ef4 100644 (file)
@@ -34,7 +34,7 @@
  #define IF_GET_IFACE  0x0001          /* for querying only */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -1878,6 +1878,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -1883,6 +1883,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -45,7 +45,7 @@
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2002,16 +2006,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2007,16 +2011,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
index d3d6aaa..fd50eb1 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2838,6 +2838,8 @@ static __net_initdata struct pernet_oper
+@@ -2839,6 +2839,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index b3f06e8..ffbc351 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index cf18ef7..71e8402 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 60af7a2..9ddcc79 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand ubifs
 CPU_TYPE:=xscale
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 0974985..8e3887f 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/marvell/mv643xx_eth.c
 +++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -2805,7 +2805,7 @@ static int mv643xx_eth_remove(struct pla
+@@ -2803,7 +2803,7 @@ static int mv643xx_eth_remove(struct pla
  
        unregister_netdev(mp->dev);
        if (mp->phy != NULL)
index caf4d10..a7c5628 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/marvell/mv643xx_eth.c
 +++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -2470,7 +2470,7 @@ static int mv643xx_eth_shared_probe(stru
+@@ -2469,7 +2469,7 @@ static int mv643xx_eth_shared_probe(stru
        if (msp == NULL)
                return -ENOMEM;
  
@@ -23,7 +23,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (msp->base == NULL)
                return -ENOMEM;
  
-@@ -2498,7 +2498,6 @@ static int mv643xx_eth_shared_remove(str
+@@ -2497,7 +2497,6 @@ static int mv643xx_eth_shared_remove(str
  {
        struct mv643xx_eth_shared_private *msp = platform_get_drvdata(pdev);
  
index 71e1a39..3179b90 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
  static char mv643xx_eth_driver_name[] = "mv643xx_eth";
  static char mv643xx_eth_driver_version[] = "1.4";
-@@ -2715,17 +2716,27 @@ static int mv643xx_eth_probe(struct plat
+@@ -2714,17 +2715,27 @@ static int mv643xx_eth_probe(struct plat
        netif_set_real_num_tx_queues(dev, mp->txq_count);
        netif_set_real_num_rx_queues(dev, mp->rxq_count);
  
index 50bafd3..7cf45a0 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  #define TX_BW_RATE                    0x0050
  #define TX_BW_MTU                     0x0058
  #define TX_BW_BURST                   0x005c
-@@ -2701,6 +2703,15 @@ static int mv643xx_eth_probe(struct plat
+@@ -2700,6 +2702,15 @@ static int mv643xx_eth_probe(struct plat
  
        mp->dev = dev;
  
index 897b261..e0eac00 100644 (file)
@@ -116,7 +116,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  #include <linux/of_mdio.h>
  
  static char mv643xx_eth_driver_name[] = "mv643xx_eth";
-@@ -2453,13 +2456,148 @@ static void infer_hw_params(struct mv643
+@@ -2452,13 +2455,148 @@ static void infer_hw_params(struct mv643
        }
  }
  
@@ -266,7 +266,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        if (!mv643xx_eth_version_printed++)
                pr_notice("MV-643xx 10/100/1000 ethernet driver version %s\n",
-@@ -2472,6 +2610,7 @@ static int mv643xx_eth_shared_probe(stru
+@@ -2471,6 +2609,7 @@ static int mv643xx_eth_shared_probe(stru
        msp = devm_kzalloc(&pdev->dev, sizeof(*msp), GFP_KERNEL);
        if (msp == NULL)
                return -ENOMEM;
@@ -274,7 +274,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        msp->base = devm_ioremap(&pdev->dev, res->start, resource_size(res));
        if (msp->base == NULL)
-@@ -2488,12 +2627,15 @@ static int mv643xx_eth_shared_probe(stru
+@@ -2487,12 +2626,15 @@ static int mv643xx_eth_shared_probe(stru
        if (dram)
                mv643xx_eth_conf_mbus_windows(msp, dram);
  
@@ -292,7 +292,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return 0;
  }
  
-@@ -2501,9 +2643,9 @@ static int mv643xx_eth_shared_remove(str
+@@ -2500,9 +2642,9 @@ static int mv643xx_eth_shared_remove(str
  {
        struct mv643xx_eth_shared_private *msp = platform_get_drvdata(pdev);
  
@@ -303,7 +303,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return 0;
  }
  
-@@ -2513,6 +2655,7 @@ static struct platform_driver mv643xx_et
+@@ -2512,6 +2654,7 @@ static struct platform_driver mv643xx_et
        .driver = {
                .name   = MV643XX_ETH_SHARED_NAME,
                .owner  = THIS_MODULE,
@@ -311,7 +311,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        },
  };
  
-@@ -2721,6 +2864,8 @@ static int mv643xx_eth_probe(struct plat
+@@ -2720,6 +2863,8 @@ static int mv643xx_eth_probe(struct plat
        if (!IS_ERR(mp->clk)) {
                clk_prepare_enable(mp->clk);
                mp->t_clk = clk_get_rate(mp->clk);
index 84ac779..12e522a 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/ethernet/marvell/mv643xx_eth.c
 +++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -2483,6 +2483,7 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2482,6 +2482,7 @@ static int mv643xx_eth_shared_of_add_por
        struct resource res;
        const char *mac_addr;
        int ret;
@@ -27,7 +27,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        memset(&ppd, 0, sizeof(ppd));
        ppd.shared = pdev;
-@@ -2503,6 +2504,14 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2502,6 +2503,14 @@ static int mv643xx_eth_shared_of_add_por
                return -EINVAL;
        }
  
@@ -42,7 +42,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        mac_addr = of_get_mac_address(pnp);
        if (mac_addr)
                memcpy(ppd.mac_addr, mac_addr, 6);
-@@ -2521,7 +2530,7 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2520,7 +2529,7 @@ static int mv643xx_eth_shared_of_add_por
                of_property_read_u32(pnp, "duplex", &ppd.duplex);
        }
  
@@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (!ppdev)
                return -ENOMEM;
        ppdev->dev.coherent_dma_mask = DMA_BIT_MASK(32);
-@@ -2538,7 +2547,7 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2537,7 +2546,7 @@ static int mv643xx_eth_shared_of_add_por
        if (ret)
                goto port_err;
  
index 7b15754..35d0a8b 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs
 SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 CPU_TYPE:=mips32r2
 
index 056f517..1911b44 100644 (file)
                                 enum mtd_parser_type type,
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -616,7 +616,7 @@ out_register:
+@@ -615,7 +615,7 @@ out_register:
  }
  
  
  __mtd_add_partition(struct mtd_info *master, char *name,
                    long long offset, long long length, bool dup_check)
  {
-@@ -737,7 +737,7 @@ run_parsers_by_type(struct mtd_part *sla
+@@ -736,7 +736,7 @@ run_parsers_by_type(struct mtd_part *sla
        return nr_parts;
  }
  
  mtd_pad_erasesize(struct mtd_info *mtd, int offset, int len)
  {
        unsigned long mask = mtd->erasesize - 1;
-@@ -806,7 +806,6 @@ static void split_uimage(struct mtd_info
+@@ -805,7 +805,6 @@ static void split_uimage(struct mtd_info
                return;
  
        len = be32_to_cpu(hdr.size) + 0x40;
index c24e1b7..fc521b9 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 DEVICE_TYPE:=developerboard
 
index 1721e95..3e7cd38 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 2b8b258..9b96422 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 0f03bda..c8de56d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index aeb0718..35f5186 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
 CPU_CFLAGS_octeon:=-march=octeon
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 317484d..ede4771 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index b9fc559..d5c459a 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 62c993f..f09f109 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x rt3883 mt7620a rt288x
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index af65043..20fc428 100644 (file)
@@ -14,11 +14,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  6 files changed, 385 insertions(+), 19 deletions(-)
  create mode 100644 drivers/pinctrl/pinctrl-rt2880.c
 
-Index: linux-3.10.17/arch/mips/Kconfig
-===================================================================
---- linux-3.10.17.orig/arch/mips/Kconfig       2013-10-26 17:19:49.094708911 +0200
-+++ linux-3.10.17/arch/mips/Kconfig    2013-10-26 17:19:49.926708932 +0200
-@@ -446,6 +446,8 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -446,6 +446,8 @@ config RALINK
        select HAVE_MACH_CLKDEV
        select CLKDEV_LOOKUP
        select ARCH_REQUIRE_GPIOLIB
@@ -27,11 +25,9 @@ Index: linux-3.10.17/arch/mips/Kconfig
  
  config SGI_IP22
        bool "SGI IP22 (Indy/Indigo2)"
-Index: linux-3.10.17/drivers/pinctrl/Kconfig
-===================================================================
---- linux-3.10.17.orig/drivers/pinctrl/Kconfig 2013-10-18 19:44:19.000000000 +0200
-+++ linux-3.10.17/drivers/pinctrl/Kconfig      2013-10-26 17:19:49.930708931 +0200
-@@ -114,6 +114,11 @@
+--- a/drivers/pinctrl/Kconfig
++++ b/drivers/pinctrl/Kconfig
+@@ -114,6 +114,11 @@ config PINCTRL_LANTIQ
        select PINMUX
        select PINCONF
  
@@ -43,11 +39,9 @@ Index: linux-3.10.17/drivers/pinctrl/Kconfig
  config PINCTRL_FALCON
        bool
        depends on SOC_FALCON
-Index: linux-3.10.17/drivers/pinctrl/Makefile
-===================================================================
---- linux-3.10.17.orig/drivers/pinctrl/Makefile        2013-10-18 19:44:19.000000000 +0200
-+++ linux-3.10.17/drivers/pinctrl/Makefile     2013-10-26 17:19:49.930708931 +0200
-@@ -45,6 +45,7 @@
+--- a/drivers/pinctrl/Makefile
++++ b/drivers/pinctrl/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_PINCTRL_EXYNOS5440)     += pinc
  obj-$(CONFIG_PINCTRL_S3C64XX) += pinctrl-s3c64xx.o
  obj-$(CONFIG_PINCTRL_XWAY)    += pinctrl-xway.o
  obj-$(CONFIG_PINCTRL_LANTIQ)  += pinctrl-lantiq.o
@@ -55,10 +49,8 @@ Index: linux-3.10.17/drivers/pinctrl/Makefile
  
  obj-$(CONFIG_PLAT_ORION)        += mvebu/
  obj-$(CONFIG_ARCH_SHMOBILE)   += sh-pfc/
-Index: linux-3.10.17/drivers/pinctrl/pinctrl-rt2880.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.17/drivers/pinctrl/pinctrl-rt2880.c     2013-10-27 16:22:50.132754888 +0100
+--- /dev/null
++++ b/drivers/pinctrl/pinctrl-rt2880.c
 @@ -0,0 +1,466 @@
 +/*
 + *  linux/drivers/pinctrl/pinctrl-rt2880.c
@@ -526,10 +518,8 @@ Index: linux-3.10.17/drivers/pinctrl/pinctrl-rt2880.c
 +}
 +
 +core_initcall_sync(rt2880_pinmux_init);
-Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/pinmux.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.17/arch/mips/include/asm/mach-ralink/pinmux.h   2013-10-27 07:28:38.999991133 +0100
+--- /dev/null
++++ b/arch/mips/include/asm/mach-ralink/pinmux.h
 @@ -0,0 +1,53 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify
@@ -584,10 +574,8 @@ Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/pinmux.h
 +extern struct rt2880_pmx_group *rt2880_pinmux_data;
 +
 +#endif
-Index: linux-3.10.17/arch/mips/ralink/mt7620.c
-===================================================================
---- linux-3.10.17.orig/arch/mips/ralink/mt7620.c       2013-10-26 17:19:49.462708921 +0200
-+++ linux-3.10.17/arch/mips/ralink/mt7620.c    2013-10-27 13:33:02.148512122 +0100
+--- a/arch/mips/ralink/mt7620.c
++++ b/arch/mips/ralink/mt7620.c
 @@ -17,6 +17,7 @@
  #include <asm/mipsregs.h>
  #include <asm/mach-ralink/ralink_regs.h>
@@ -596,7 +584,7 @@ Index: linux-3.10.17/arch/mips/ralink/mt7620.c
  
  #include "common.h"
  
-@@ -48,118 +49,58 @@
+@@ -48,118 +49,58 @@ static int dram_type;
  /* the pll dividers */
  static u32 mt7620_clk_divider[] = { 2, 3, 4, 8 };
  
@@ -764,17 +752,15 @@ Index: linux-3.10.17/arch/mips/ralink/mt7620.c
  };
  
  void __init ralink_clk_init(void)
-@@ -281,4 +222,6 @@
+@@ -281,4 +222,6 @@ void prom_soc_init(struct ralink_soc_inf
                (pmu0 & PMU_SW_SET) ? ("sw") : ("hw"));
        pr_info("Digital PMU set to %s control\n",
                (pmu1 & DIG_SW_SEL) ? ("sw") : ("hw"));
 +
 +      rt2880_pinmux_data = mt7620a_pinmux_data;
  }
-Index: linux-3.10.17/arch/mips/ralink/rt305x.c
-===================================================================
---- linux-3.10.17.orig/arch/mips/ralink/rt305x.c       2013-10-26 17:19:49.722708926 +0200
-+++ linux-3.10.17/arch/mips/ralink/rt305x.c    2013-10-27 16:23:29.836755834 +0100
+--- a/arch/mips/ralink/rt305x.c
++++ b/arch/mips/ralink/rt305x.c
 @@ -17,90 +17,71 @@
  #include <asm/mipsregs.h>
  #include <asm/mach-ralink/ralink_regs.h>
@@ -924,7 +910,7 @@ Index: linux-3.10.17/arch/mips/ralink/rt305x.c
  };
  
  static void rt305x_wdt_reset(void)
-@@ -114,14 +95,6 @@
+@@ -114,14 +95,6 @@ static void rt305x_wdt_reset(void)
        rt_sysc_w32(t, SYSC_REG_SYSTEM_CONFIG);
  }
  
@@ -939,7 +925,7 @@ Index: linux-3.10.17/arch/mips/ralink/rt305x.c
  static unsigned long rt5350_get_mem_size(void)
  {
        void __iomem *sysc = (void __iomem *) KSEG1ADDR(RT305X_SYSC_BASE);
-@@ -291,11 +264,14 @@
+@@ -291,11 +264,14 @@ void prom_soc_init(struct ralink_soc_inf
        soc_info->mem_base = RT305X_SDRAM_BASE;
        if (soc_is_rt5350()) {
                soc_info->mem_size = rt5350_get_mem_size();
@@ -954,11 +940,9 @@ Index: linux-3.10.17/arch/mips/ralink/rt305x.c
 +              rt2880_pinmux_data = rt3352_pinmux_data;
        }
  }
-Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/rt305x.h
-===================================================================
---- linux-3.10.17.orig/arch/mips/include/asm/mach-ralink/rt305x.h      2013-10-18 19:44:19.000000000 +0200
-+++ linux-3.10.17/arch/mips/include/asm/mach-ralink/rt305x.h   2013-10-26 17:19:49.934708931 +0200
-@@ -125,24 +125,28 @@
+--- a/arch/mips/include/asm/mach-ralink/rt305x.h
++++ b/arch/mips/include/asm/mach-ralink/rt305x.h
+@@ -125,24 +125,28 @@ static inline int soc_is_rt5350(void)
  #define RT305X_GPIO_GE0_TXD0          40
  #define RT305X_GPIO_GE0_RXCLK         51
  
@@ -1002,10 +986,8 @@ Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/rt305x.h
  
  #define RT3352_SYSC_REG_SYSCFG0               0x010
  #define RT3352_SYSC_REG_SYSCFG1         0x014
-Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/mt7620.h
-===================================================================
---- linux-3.10.17.orig/arch/mips/include/asm/mach-ralink/mt7620.h      2013-10-26 17:19:49.250708916 +0200
-+++ linux-3.10.17/arch/mips/include/asm/mach-ralink/mt7620.h   2013-10-27 13:13:24.892484072 +0100
+--- a/arch/mips/include/asm/mach-ralink/mt7620.h
++++ b/arch/mips/include/asm/mach-ralink/mt7620.h
 @@ -59,7 +59,6 @@
  #define MT7620_DDR2_SIZE_MIN          32
  #define MT7620_DDR2_SIZE_MAX          256
@@ -1060,10 +1042,8 @@ Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/mt7620.h
 +#define MT7620_GPIO_MODE_PA           20
  
  #endif
-Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/rt3883.h
-===================================================================
---- linux-3.10.17.orig/arch/mips/include/asm/mach-ralink/rt3883.h      2013-10-18 19:44:19.000000000 +0200
-+++ linux-3.10.17/arch/mips/include/asm/mach-ralink/rt3883.h   2013-10-26 17:19:49.934708931 +0200
+--- a/arch/mips/include/asm/mach-ralink/rt3883.h
++++ b/arch/mips/include/asm/mach-ralink/rt3883.h
 @@ -112,8 +112,6 @@
  #define RT3883_CLKCFG1_PCI_CLK_EN     BIT(19)
  #define RT3883_CLKCFG1_UPHY0_CLK_EN   BIT(18)
@@ -1094,10 +1074,8 @@ Index: linux-3.10.17/arch/mips/include/asm/mach-ralink/rt3883.h
  #define RT3883_GPIO_MODE_PCI_SHIFT    11
  #define RT3883_GPIO_MODE_PCI_MASK     0x7
  #define RT3883_GPIO_MODE_PCI          (RT3883_GPIO_MODE_PCI_MASK << RT3883_GPIO_MODE_PCI_SHIFT)
-Index: linux-3.10.17/arch/mips/ralink/common.h
-===================================================================
---- linux-3.10.17.orig/arch/mips/ralink/common.h       2013-10-26 17:19:49.094708911 +0200
-+++ linux-3.10.17/arch/mips/ralink/common.h    2013-10-26 17:19:49.934708931 +0200
+--- a/arch/mips/ralink/common.h
++++ b/arch/mips/ralink/common.h
 @@ -11,25 +11,6 @@
  
  #define RAMIPS_SYS_TYPE_LEN   32
@@ -1124,10 +1102,8 @@ Index: linux-3.10.17/arch/mips/ralink/common.h
  struct ralink_soc_info {
        unsigned char sys_type[RAMIPS_SYS_TYPE_LEN];
        unsigned char *compatible;
-Index: linux-3.10.17/arch/mips/ralink/rt3883.c
-===================================================================
---- linux-3.10.17.orig/arch/mips/ralink/rt3883.c       2013-10-18 19:44:19.000000000 +0200
-+++ linux-3.10.17/arch/mips/ralink/rt3883.c    2013-10-27 16:23:36.824756002 +0100
+--- a/arch/mips/ralink/rt3883.c
++++ b/arch/mips/ralink/rt3883.c
 @@ -17,132 +17,50 @@
  #include <asm/mipsregs.h>
  #include <asm/mach-ralink/ralink_regs.h>
@@ -1299,7 +1275,7 @@ Index: linux-3.10.17/arch/mips/ralink/rt3883.c
  };
  
  static void rt3883_wdt_reset(void)
-@@ -155,17 +73,6 @@
+@@ -155,17 +73,6 @@ static void rt3883_wdt_reset(void)
        rt_sysc_w32(t, RT3883_SYSC_REG_SYSCFG1);
  }
  
@@ -1317,7 +1293,7 @@ Index: linux-3.10.17/arch/mips/ralink/rt3883.c
  void __init ralink_clk_init(void)
  {
        unsigned long cpu_rate, sys_rate;
-@@ -243,4 +150,6 @@
+@@ -243,4 +150,6 @@ void prom_soc_init(struct ralink_soc_inf
        soc_info->mem_base = RT3883_SDRAM_BASE;
        soc_info->mem_size_min = RT3883_MEM_SIZE_MIN;
        soc_info->mem_size_max = RT3883_MEM_SIZE_MAX;
index b03263c..9c5a728 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -806,10 +806,6 @@ static void split_uimage(struct mtd_info
+@@ -805,10 +805,6 @@ static void split_uimage(struct mtd_info
                return;
  
        len = be32_to_cpu(hdr.size) + 0x40;
index 12eb9b3..8a6a281 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz broken
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index eb3ab53..0524144 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 DEVICE_TYPE:=developerboard
 
index bff78e5..e60f550 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz
 SUBTARGETS=cortex-a7 cortex-a8
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
index df046fb..028874b 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 CS5535_MASK:=0x0b000042
 
 CPU_TYPE := geode
index d95c0dc..348779d 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 define Target/Description
        Build firmware images for x86 based boards
index 4f89fd5..351ca74 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
 
 DEVICE_TYPE=other