kernel: update linux 3.7 to 3.7.6
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Feb 2013 10:02:56 +0000 (10:02 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Feb 2013 10:02:56 +0000 (10:02 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35476 3c298f89-4303-0410-b956-a3cf2f4a3e73

17 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/250-netfilter_depends.patch
target/linux/generic/patches-3.7/600-netfilter_layer7_2.22.patch
target/linux/generic/patches-3.7/603-netfilter_layer7_2.6.36_fix.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/geos/target.mk

index d5feae3..5d402f0 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.5)
-  LINUX_KERNEL_MD5SUM:=ae355001775bc841132fe0fea2f354d4
+ifeq ($(LINUX_VERSION),3.7.6)
+  LINUX_KERNEL_MD5SUM:=4c4d80619c713f83015fc6b1c6280891
 endif
 
 # disable the md5sum check for unknown kernel versions
index fe919da..5f31bc5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 315db0e..4a9a15d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
index 630d8d2..0a285f9 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
index 3c90134..218df4c 100644 (file)
@@ -8,7 +8,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -750,7 +749,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -757,7 +756,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index 0c8c5e8..55daeab 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -1176,6 +1176,27 @@ config NETFILTER_XT_MATCH_STATE
+@@ -1183,6 +1183,27 @@ config NETFILTER_XT_MATCH_STATE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
index 23a1b1b..e3f2032 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -980,6 +980,27 @@ config NETFILTER_XT_MATCH_IPVS
+@@ -987,6 +987,27 @@ config NETFILTER_XT_MATCH_IPVS
  
          If unsure, say N.
  
@@ -28,7 +28,7 @@
  config NETFILTER_XT_MATCH_LENGTH
        tristate '"length" match support'
        depends on NETFILTER_ADVANCED
-@@ -1176,26 +1197,11 @@ config NETFILTER_XT_MATCH_STATE
+@@ -1183,26 +1204,11 @@ config NETFILTER_XT_MATCH_STATE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
index febdecc..a7241f0 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index fbf6f81..7d9d08e 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 DEVICE_TYPE:=developerboard
 
index dcd1a8c..552d972 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
index b521077..3950c6d 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
index 4a57f21..871c5b0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
index 68e5a57..a5879dd 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a5f811..5d0a643 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 69f01b7..7044f10 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index e10e169..f215751 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index c82b189..90ed8f3 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \