[ImageBuilder] fix profile package selection, packages from last parsed profile were...
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Jul 2009 07:24:50 +0000 (07:24 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Jul 2009 07:24:50 +0000 (07:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16653 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/files/Makefile

index b526925..c7f4355 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -81,7 +81,7 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
        @echo 'dest root /' > $@
        @echo 'src packages file:$(PACKAGE_DIR)' >> $@
 
-BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
+BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $($(PROFILE)_PACKAGES) kernel)
 ifeq ($(KERNEL),2.4)
 BUILD_PACKAGES:=$(patsubst base-files,base-files-$(BOARD)-$(KERNEL),$(BUILD_PACKAGES))
 else