Revert "include/autoconf.mk: decouple host fixups from target fixups"
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Jan 2016 20:46:20 +0000 (20:46 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Jan 2016 20:46:20 +0000 (20:46 +0000)
This reverts commit r48403

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48412 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index 3e028fa..3316998 100644 (file)
@@ -143,21 +143,27 @@ define patch_libtool_host
     $(HOST_BUILD_DIR)))
 endef
 
-ifneq ($(filter patch-libtool-host,$(PKG_FIXUP)),)
+ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
   Hooks/HostConfigure/Pre += patch_libtool_host
 endif
 
-ifneq ($(filter patch-libtool-host,$(HOST_FIXUP)),)
+ifneq ($(filter patch-libtool,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += $(strip $(call patch_libtool,$(HOST_BUILD_DIR)))
 endif
 
-ifneq ($(filter libtool-host,$(HOST_FIXUP)),)
+ifneq ($(filter libtool,$(HOST_FIXUP)),)
+ ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
+  Hooks/HostConfigure/Pre += autoreconf_host
+ endif
+endif
+
+ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif
 endif
 
-ifneq ($(filter autoreconf-host,$(HOST_FIXUP)),)
+ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
     Hooks/HostConfigure/Pre += autoreconf_host
   endif