toolchain: Add libatomic when using external toolchain
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jan 2015 13:58:03 +0000 (13:58 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jan 2015 13:58:03 +0000 (13:58 +0000)
Otherwise libatomic cannot be used in conjunction with external toolchains.

Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43998 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/toolchain/Makefile

index 1a75e90..42b9935 100644 (file)
@@ -604,6 +604,15 @@ else
        exit 0
   endef
 
+  define Package/libatomic/install
+       for file in $(call qstrip,$(CONFIG_LIBATOMIC_FILE_SPEC)); do \
+               dir=`dirname $$$$file` ; \
+               $(INSTALL_DIR) $(1)/$$$$dir ; \
+               $(CP) $(call qstrip,$(CONFIG_LIBATOMIC_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
+       done ; \
+       exit 0
+  endef
+
   define Package/ldd/install
        for file in $(call qstrip,$(CONFIG_LDD_FILE_SPEC)); do \
                dir=`dirname $$$$file` ; \