[package] add a cross-version of ksymoops
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Jun 2009 21:35:39 +0000 (21:35 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Jun 2009 21:35:39 +0000 (21:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16575 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ksymoops/Makefile [new file with mode: 0644]

diff --git a/package/ksymoops/Makefile b/package/ksymoops/Makefile
new file mode 100644 (file)
index 0000000..be6f9b6
--- /dev/null
@@ -0,0 +1,55 @@
+# 
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=ksymoops
+PKG_VERSION:=2.4.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/ksymoops/v2.4/
+PKG_MD5SUM:=4a8249e182a5dbc75e566d162e9f3314
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ksymoops
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6 @TARGET_mips||TARGET_mips||TARGET_m68k||TARGET_x86 +libbfd
+  TITLE:=Interpret oops of the kernel
+  URL:=http://www.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4/
+  MENU:=1
+endef
+
+define Package/kexec-tools/description
+endef
+
+define Build/Configure
+endef
+
+TARGET=$(strip $(shell echo $(TARGET_CFLAGS) | cut -d- -f4 | cut -d= -f2))
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               BFD_PREFIX="$(STAGING_DIR)/usr" \
+               DEF_TARGET='\"$(TARGET)\"' \
+               DEF_ARCH='\"$(ARCH)\"' \
+               DEF_MAP='\"$(LINUX_DIR)/System.map\"' \
+               CROSS="$(TARGET_CROSS)" \
+               INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/ksymoops/install
+       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/$(TARGET_CROSS)ksymoops $(1)/bin/ksymoops
+endef
+
+$(eval $(call BuildPackage,ksymoops))