libnl-tiny: fix receiving netlink messages larger than 4K
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Dec 2014 19:35:48 +0000 (19:35 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Dec 2014 19:35:48 +0000 (19:35 +0000)
Apply libnl commit 807fddc4cd9ecb12ba64e1b7fa26d86b6c2f19b0 ("nl:
Increase receive buffer size to 4 pages") also to libnl-tiny to ensure
netlink messages larger than 4KiB can be received, as the restart logic
seems to be broken.

This fixes iwinfo accessing info on dual band b43 cards, as they can
support a lot of channels, breaking the 4K default limit (seen was >5k).

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43633 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/libnl-tiny/Makefile
package/libs/libnl-tiny/src/nl.c

index b3957b0..2445ad4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl-tiny
 PKG_VERSION:=0.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_LICENSE:=LGPL-2.1
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
index 99e9aeb..ea7d968 100644 (file)
@@ -397,7 +397,7 @@ int nl_recv(struct nl_sock *sk, struct sockaddr_nl *nla,
                flags |= MSG_PEEK;
 
        if (page_size == 0)
-               page_size = getpagesize();
+               page_size = getpagesize() * 4;
 
        iov.iov_len = page_size;
        iov.iov_base = *buf = malloc(iov.iov_len);