ubox: add a uci-default script for fstab generation
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Jul 2013 09:01:42 +0000 (09:01 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Jul 2013 09:01:42 +0000 (09:01 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37199 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/ubox/Makefile
package/system/ubox/files/fstab.default [new file with mode: 0644]

index 3824148..e964506 100644 (file)
@@ -48,9 +48,10 @@ define Package/ubox/install
 endef
 
 define Package/block-mount/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+       $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
        $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
diff --git a/package/system/ubox/files/fstab.default b/package/system/ubox/files/fstab.default
new file mode 100644 (file)
index 0000000..dd4ba1c
--- /dev/null
@@ -0,0 +1 @@
+[ ! -f /etc/config/fstab ] && ( block detect > /etc/config/fstab )