grub2: use the static lzma lib instead of the dynamic one
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Sep 2012 10:38:06 +0000 (10:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Sep 2012 10:38:06 +0000 (10:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33526 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/grub2/Makefile

index 2a2244a..b606f54 100644 (file)
@@ -39,7 +39,8 @@ HOST_CONFIGURE_ARGS += \
        --disable-nls
 
 HOST_MAKE_FLAGS += \
-       TARGET_RANLIB=$(TARGET_RANLIB)
+       TARGET_RANLIB=$(TARGET_RANLIB) \
+       LIBLZMA=$(STAGING_DIR_HOST)/lib/liblzma.a
 
 define Host/Configure
        $(SED) 's,(RANLIB),(TARGET_RANLIB),' $(HOST_BUILD_DIR)/grub-core/Makefile.in