Add sch_fq and sch_pie to the kmod-sched package.
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Jun 2015 05:44:44 +0000 (05:44 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Jun 2015 05:44:44 +0000 (05:44 +0000)
These are two new packet schedulers introduced in Linux 3.12 and 3.14
respectively. sch_fq is a perfect fairness queueing scheduler that also
adds pacing on host TCP flows, and sch_pie is an AQM.

Having them available in kmod-sched makes it easier for people to test
these new queueing schemes.

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45885 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netsupport.mk

index 4483581..adfdace 100644 (file)
@@ -802,6 +802,8 @@ define KernelPackage/sched
        CONFIG_NET_SCH_TBF \
        CONFIG_NET_SCH_SFQ \
        CONFIG_NET_SCH_TEQL \
+       CONFIG_NET_SCH_FQ \
+       CONFIG_NET_SCH_PIE \
        CONFIG_NET_CLS_BASIC \
        CONFIG_NET_ACT_POLICE \
        CONFIG_NET_ACT_IPT \