netifd: fix default ORO-setting for 6rd
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Nov 2014 12:24:49 +0000 (12:24 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Nov 2014 12:24:49 +0000 (12:24 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43214 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/config/netifd/Makefile
package/network/config/netifd/files/lib/netifd/proto/dhcp.sh

index 008af61..ea8980f 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2014-10-24
+PKG_VERSION:=2014-10-24.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
index 6668b49..d4c483d 100755 (executable)
@@ -40,7 +40,7 @@ proto_dhcp_setup() {
        [ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
        [ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
        [ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
-       [ -n "$iface6rd" ] && append dhcpopts "-O 212"
+       [ "$iface6rd" != 0 -a -f /lib/netifd/proto/6rd.sh ] && append dhcpopts "-O 212"
        [ -n "$zone6rd" ] && proto_export "ZONE6RD=$zone6rd"
        [ -n "$zone" ] && proto_export "ZONE=$zone"
        [ -n "$mtu6rd" ] && proto_export "MTU6RD=$mtu6rd"