include: rework git prereq test to not require 'man'
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Feb 2015 11:50:08 +0000 (11:50 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Feb 2015 11:50:08 +0000 (11:50 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44292 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index 1c8de06..7945f05 100644 (file)
@@ -143,7 +143,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
-       git clone --help | grep -- --recursive))
+       git clone 2>&1 | grep -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version | grep file))