brcm2708: add Raspberry Pi Compute Module support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jul 2015 12:49:27 +0000 (12:49 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jul 2015 12:49:27 +0000 (12:49 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46403 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
target/linux/brcm2708/image/Makefile

index 82a7910..dcf6e05 100644 (file)
@@ -28,3 +28,11 @@ define Profile/RaspberryPi_BPlus/Description
   Raspberry Pi Model B+
 endef
 $(eval $(call Profile,RaspberryPi_BPlus))
+
+define Profile/RaspberryPi_CM
+  NAME:=Raspberry Pi Compute Module
+endef
+define Profile/RaspberryPi_CM/Description
+  Raspberry Pi Model Compute Module
+endef
+$(eval $(call Profile,RaspberryPi_CM))
index 00bee22..de178c6 100644 (file)
@@ -73,6 +73,8 @@ ifeq ($(SUBTARGET),bcm2708)
   $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
   # Raspberry Pi Model B+
   $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+  # Raspberry Pi Compute Module
+  $(eval $(call add_bcm2708,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
 endif
 
 ### BCM2709/BCM2836 ###