busybox: fix broken default for FEATURE_IP_ROUTE_DIR (#21845)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2016 19:46:31 +0000 (19:46 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2016 19:46:31 +0000 (19:46 +0000)
Changeset r47775 introduced a wrong default value "n" for the ip applets
config search path, breaking the handling of named routing tables and other
objects having alias configurations.

Fix the issue by providing a proper default value aligned with the value
used by full iproute2.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48716 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/busybox/Config-defaults.in
package/utils/busybox/Makefile

index 3df4cda..ee42fa1 100644 (file)
@@ -2172,7 +2172,7 @@ config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE
        default y
 config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE_DIR
        string
-       default "n"
+       default "/etc/iproute2"
 config BUSYBOX_DEFAULT_FEATURE_IP_TUNNEL
        bool
        default n
index 95e785b..6a55d56 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.24.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2