fstools: stage libubi-utils static library and headers
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:44:16 +0000 (12:44 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:44:16 +0000 (12:44 +0000)
Use InstallDev to make libubi-utils available for linking in
uboot-envtools.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40928 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/fstools/Makefile

index 40adf0a..b10f105 100644 (file)
@@ -78,6 +78,13 @@ define Package/block-mount/install
 
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libubi-utils.a $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,fstools))
 $(eval $(call BuildPackage,ubi-flash))
 $(eval $(call BuildPackage,block-mount))