build: remove leftover olpc support code
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Mar 2015 11:40:06 +0000 (11:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 28 Mar 2015 11:40:06 +0000 (11:40 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45084 3c298f89-4303-0410-b956-a3cf2f4a3e73

config/Config-images.in
package/kernel/linux/modules/sound.mk

index a420c39..a563b38 100644 (file)
@@ -186,7 +186,7 @@ menu "Target Images"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
-               depends on TARGET_x86_64 || (TARGET_x86 && !(TARGET_x86_olpc || TARGET_x86_rdc))
+               depends on TARGET_x86_64 || (TARGET_x86 && !TARGET_x86_rdc)
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                default y
@@ -241,7 +241,7 @@ menu "Target Images"
 
        config TARGET_IMAGES_PAD
                bool "Pad images to filesystem size (for JFFS2)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
+               depends on GRUB_IMAGES
 
        config TARGET_IMAGES_GZIP
                bool "GZip images"
@@ -254,7 +254,7 @@ menu "Target Images"
 
        config TARGET_KERNEL_PARTSIZE
                int "Kernel partition size (in MB)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
+               depends on GRUB_IMAGES
                default 4
 
        config TARGET_ROOTFS_PARTSIZE
@@ -266,7 +266,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_PARTNAME
                string "Root partition on target device"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
+               depends on GRUB_IMAGES
                help
                  Override the root partition on the final device. If left empty,
                  it will be mounted by PARTUUID which makes the kernel find the
index 964524b..9a3caed 100644 (file)
@@ -145,22 +145,6 @@ endef
 $(eval $(call KernelPackage,sound-i8x0))
 
 
-define KernelPackage/sound-cs5535audio
-  TITLE:=CS5535 PCI Controller
-  DEPENDS:=+kmod-ac97
-  KCONFIG:=CONFIG_SND_CS5535AUDIO
-  FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
-  AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
-  $(call AddDepends/sound)
-endef
-
-define KernelPackage/sound-cs5535audio/description
- Support for the integrated AC97 sound device on olpc
-endef
-
-$(eval $(call KernelPackage,sound-cs5535audio))
-
-
 define KernelPackage/sound-soc-core
   TITLE:=SoC sound support
   DEPENDS:=+kmod-regmap +kmod-ac97