sdk: use prepare target to initialize git snapshot
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Feb 2015 22:54:27 +0000 (22:54 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Feb 2015 22:54:27 +0000 (22:54 +0000)
The new approach is less prone to race conditions and will properly
snapshot the symlinks prepared by the prereq-build target.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44330 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/sdk/Makefile
target/sdk/files/Makefile
target/sdk/files/include/prepare.mk [new file with mode: 0644]

index 8ae63c4..d81c237 100644 (file)
@@ -98,6 +98,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
                $(TOPDIR)/.config \
                ./files/Config.in \
                ./files/Makefile \
+               ./files/include/prepare.mk \
                ./files/README.SDK \
                $(SDK_BUILD_DIR)/
        $(CP) \
index 01c1e1c..2edf7b3 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,16 +14,6 @@ export TOPDIR LC_ALL LANG SDK
 
 world:
 
-# Initialize SDK snapshot
-.git/config:
-       @( \
-               echo -n "Initializing SDK ... "; \
-               git init -q .; \
-               find . -mindepth 1 -maxdepth 1 -not -name feeds | xargs git add; \
-               git commit -q -m "Initial state"; \
-               echo "ok."; \
-       )
-
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
diff --git a/target/sdk/files/include/prepare.mk b/target/sdk/files/include/prepare.mk
new file mode 100644 (file)
index 0000000..76bad05
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+prepare: .git/config
+
+.git/config:
+       @( \
+               printf "Initializing SDK ... "; \
+               git init -q .; \
+               find . -mindepth 1 -maxdepth 1 -not -name feeds | xargs git add; \
+               git commit -q -m "Initial state"; \
+               echo "ok."; \
+       )