kernel: update linux 3.7 to 3.7.7
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Feb 2013 09:51:11 +0000 (09:51 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Feb 2013 09:51:11 +0000 (09:51 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35571 3c298f89-4303-0410-b956-a3cf2f4a3e73

18 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/102-ehci_hcd_ignore_oc.patch
target/linux/generic/patches-3.7/811-pci_disable_usb_common_quirks.patch
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.7/0123-USB-fix-roothub-for-IFXHCD.patch
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/geos/target.mk

index 5d402f0..58e911a 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.6)
-  LINUX_KERNEL_MD5SUM:=4c4d80619c713f83015fc6b1c6280891
+ifeq ($(LINUX_VERSION),3.7.7)
+  LINUX_KERNEL_MD5SUM:=bd37c2e05cb82331eb00da81773b2d85
 endif
 
 # disable the md5sum check for unknown kernel versions
index 5f31bc5..74b90d4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 4a9a15d..1227df1 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 4316531..206763d 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 0a285f9..96d90f3 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index bf1815a..dfcfc26 100644 (file)
@@ -20,7 +20,7 @@
                mask = PORT_CSC | PORT_PEC | PORT_OCC;
        else
                mask = PORT_CSC | PORT_PEC;
-@@ -804,7 +804,7 @@ static int ehci_hub_control (
+@@ -808,7 +808,7 @@ static int ehci_hub_control (
                if (temp & PORT_PEC)
                        status |= USB_PORT_STAT_C_ENABLE << 16;
  
index 1c90a5c..da73f67 100644 (file)
@@ -39,7 +39,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -973,3 +988,4 @@ static void __devinit quirk_usb_early_ha
+@@ -974,3 +989,4 @@ static void __devinit quirk_usb_early_ha
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
index a7241f0..650b90f 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index d4eae8b..2eb2317 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 123/123] USB: fix roothub for IFXHCD
 
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -3906,7 +3906,7 @@ hub_port_init (struct usb_hub *hub, stru
+@@ -3940,7 +3940,7 @@ hub_port_init (struct usb_hub *hub, stru
                udev->ttport = hdev->ttport;
        } else if (udev->speed != USB_SPEED_HIGH
                        && hdev->speed == USB_SPEED_HIGH) {
index 7d9d08e..efa17d9 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 DEVICE_TYPE:=developerboard
 
index 552d972..d7023cb 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 3950c6d..a7d4330 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 871c5b0..b7dac46 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index a5879dd..3cd2e2a 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 5d0a643..8071925 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 7044f10..c1672c2 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index f215751..2978729 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 90ed8f3..d1f7307 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \