ramips: check size after padding
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 May 2015 14:56:22 +0000 (14:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 May 2015 14:56:22 +0000 (14:56 +0000)
Signed-off-by: Cristian Morales Vega <cristian@samknows.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45777 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index b0b3579..422366c 100644 (file)
@@ -35,7 +35,7 @@ define Device/Default
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | check-size $$$$(IMAGE_SIZE) | pad-rootfs
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Build/patch-dtb