[lantiq] add subtarget, as of 3.6 we dont seperate xway SoC
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Nov 2012 20:07:36 +0000 (20:07 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Nov 2012 20:07:36 +0000 (20:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34062 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/xway/config-default [new file with mode: 0644]
target/linux/lantiq/xway/profiles/001-lantiq.mk [new file with mode: 0644]
target/linux/lantiq/xway/target.mk [new file with mode: 0644]

diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
new file mode 100644 (file)
index 0000000..655784a
--- /dev/null
@@ -0,0 +1,18 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+# CONFIG_MTD_SM_COMMON is not set
+# CONFIG_PROC_DEVICETREE is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_MASTER=y
+CONFIG_USB_SUPPORT=y
diff --git a/target/linux/lantiq/xway/profiles/001-lantiq.mk b/target/linux/lantiq/xway/profiles/001-lantiq.mk
new file mode 100644 (file)
index 0000000..2c24d3c
--- /dev/null
@@ -0,0 +1,19 @@
+define Profile/EASY80920-NOR
+  NAME:=EASY80920-NOR
+endef
+
+define Profile/EASY80920-NOR/Description
+       Lantiq EASY80920 evalkit (NOR)
+endef
+
+$(eval $(call Profile,EASY80920-NOR))
+
+define Profile/EASY80920-NAND
+  NAME:=EASY80920-NAND
+endef
+
+define Profile/EASY80920-NAND/Description
+       Lantiq EASY80920 evalkit (NAND)
+endef
+
+$(eval $(call Profile,EASY80920-NAND))
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
new file mode 100644 (file)
index 0000000..6674665
--- /dev/null
@@ -0,0 +1,10 @@
+ARCH:=mips
+SUBTARGET:=xway
+BOARDNAME:=XWAY
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=swconfig kmod-leds-gpio kmod-button-hotplug
+
+define Target/Description
+       Lantiq XWAY
+endef