toolchain/musl: remove old CONFIG_MUSL_ENABLE_DEBUG option
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Jan 2016 23:44:44 +0000 (23:44 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Jan 2016 23:44:44 +0000 (23:44 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48387 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/Config.in
toolchain/musl/Config.in [deleted file]
toolchain/musl/common.mk

index c7072fc..1eb99e3 100644 (file)
@@ -236,7 +236,6 @@ endchoice
 
 source "toolchain/glibc/Config.in"
 source "toolchain/uClibc/Config.in"
-source "toolchain/musl/Config.in"
 
 comment "Debuggers"
        depends on TOOLCHAINOPTS
diff --git a/toolchain/musl/Config.in b/toolchain/musl/Config.in
deleted file mode 100644 (file)
index 05caa6a..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-# Debug version.
-
-config MUSL_ENABLE_DEBUG
-       bool "Build with debug information"
-       depends on TOOLCHAINOPTS && USE_MUSL
-       default n
index 986f372..29beb14 100644 (file)
@@ -40,11 +40,6 @@ MUSL_CONFIGURE:= \
                --disable-gcc-wrapper \
                --enable-debug
 
-ifeq ($(CONFIG_MUSL_ENABLE_DEBUG),y)
-MUSL_CONFIGURE+= \
-       --enable-debug
-endif
-
 define Host/Prepare
        $(call Host/Prepare/Default)
        $(if $(strip $(QUILT)), \