add an initscript
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Jul 2005 22:57:30 +0000 (22:57 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Jul 2005 22:57:30 +0000 (22:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1535 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/portmap/Makefile

index 5dd79f9..20bba96 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portmap
 PKG_VERSION:=5beta
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=781e16ed4487c4caa082c6fef09ead4f
 
 # space separated list or special @SF for sourceforge projects
@@ -31,6 +31,9 @@ $(PKG_BUILD_DIR)/.built:
        touch $@
 
 $(IPKG_PORTMAP):
+       install -d -m0755 $(IDIR_PORTMAP)/etc/init.d 
+       install -m0755 ./files/portmap.init $(IDIR_PORTMAP)/etc/init.d/portmap
+       ln -sf portmap $(IDIR_PORTMAP)/etc/init.d/S59portmap
        install -d -m0755 $(IDIR_PORTMAP)/usr/sbin 
        install -m0755 $(PKG_BUILD_DIR)/portmap $(IDIR_PORTMAP)/usr/sbin/
        $(RSTRIP) $(IDIR_PORTMAP)