kirkwood: cosmetic: move POGOE02 profile to different file
[openwrt.git] / target / linux / kirkwood / profiles / 110-nas.mk
index 07a9797..eff5952 100644 (file)
@@ -8,7 +8,6 @@
 define Profile/DOCKSTAR
   NAME:=Seagate FreeAgent Dockstar
   PACKAGES:= \
-       kmod-ata-core kmod-ata-marvell-sata \
        kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
        uboot-envtools
 endef
@@ -22,20 +21,22 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,DOCKSTAR))
 
-define Profile/ICONNECT
-  NAME:=Iomega Iconnect
+define Profile/GOFLEXNET
+  NAME:=Seagate GoFlexNet
   PACKAGES:= \
-       kmod-usb2 kmod-usb-storage
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+       uboot-envtools
 endef
 
-define Profile/ICONNECT/Description
- Package set compatible with Iomega Iconnect board.
+define Profile/GOFLEXNET/Description
+ Package set compatible with Seagate GoFlexNet
 endef
 
-ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+GOFLEXNET_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GOFLEXNET_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
-$(eval $(call Profile,ICONNECT))
+$(eval $(call Profile,GOFLEXNET))
 
 define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
@@ -53,3 +54,33 @@ IB62X0_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
 IB62X0_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,IB62X0))
+
+define Profile/ICONNECT
+  NAME:=Iomega Iconnect
+  PACKAGES:= \
+       kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/ICONNECT/Description
+ Package set compatible with Iomega Iconnect board.
+endef
+
+ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,ICONNECT))
+
+define Profile/POGOE02
+  NAME:=Cloud Engines Pogoplug E02
+  PACKAGES:= \
+       kmod-usb2 kmod-usb-storage uboot-envtools
+endef
+
+define Profile/POGOE02/Description
+ Package set compatible with Cloud Engines Pogoplug E02 board.
+endef
+
+POGOE02_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,POGOE02))