netsupport: l2tp-ip: only depend on IPv6 if IPv6 support is enabled
[openwrt.git] / package / kernel / linux / modules / netsupport.mk
index 7ec3d29..4483581 100644 (file)
@@ -895,11 +895,13 @@ $(eval $(call KernelPackage,l2tp-eth))
 
 define KernelPackage/l2tp-ip
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=L2TP IP + IPv6 encapsulation for L2TPv3
-  DEPENDS:=+kmod-l2tp +kmod-ipv6
+  TITLE:=L2TP IP encapsulation for L2TPv3
+  DEPENDS:=+kmod-l2tp +IPV6:kmod-ipv6
   KCONFIG:=CONFIG_L2TP_IP
-  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.ko $(LINUX_DIR)/net/l2tp/l2tp_ip6.ko
-  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip l2tp_ip6)
+  FILES:= \
+       $(LINUX_DIR)/net/l2tp/l2tp_ip.ko \
+       $(if $(CONFIG_IPV6),$(LINUX_DIR)/net/l2tp/l2tp_ip6.ko)
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip $(if $(CONFIG_IPV6),l2tp_ip6))
 endef
 
 define KernelPackage/l2tp-ip/description