grub2: use the static lzma lib instead of the dynamic one
[openwrt.git] / package / grub2 / Makefile
index 2a2244a..b606f54 100644 (file)
@@ -39,7 +39,8 @@ HOST_CONFIGURE_ARGS += \
        --disable-nls
 
 HOST_MAKE_FLAGS += \
-       TARGET_RANLIB=$(TARGET_RANLIB)
+       TARGET_RANLIB=$(TARGET_RANLIB) \
+       LIBLZMA=$(STAGING_DIR_HOST)/lib/liblzma.a
 
 define Host/Configure
        $(SED) 's,(RANLIB),(TARGET_RANLIB),' $(HOST_BUILD_DIR)/grub-core/Makefile.in