ar71xx: rename firmware for Chinese version of TL-WR941ND v6
authorJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:14:59 +0000 (08:14 +0000)
committerJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:14:59 +0000 (08:14 +0000)
It seems there are two *different* versions on TL-WR941ND v6: Chinese
and European one. Currently supported by OpenWrt is Chinese one. Rename
firmware to make it clear.
For details see:
http://wiki.openwrt.org/toh/tp-link/tl-wr941nd
https://forum.openwrt.org/viewtopic.php?id=59295

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Backport of r47107

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48859 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 05ef1d2..24c60f5 100644 (file)
@@ -598,13 +598,14 @@ define Device/tl-wr941nd-v5
     TPLINK_HWID := 0x09410005
 endef
 
-define Device/tl-wr941nd-v6
+# Chinese version (unlike European) is similar to the TL-WDR3500
+define Device/tl-wr941nd-v6-cn
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WDR3500
     DEVICE_PROFILE := TLWR941
     TPLINK_HWID := 0x09410006
 endef
-TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6
+TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6-cn
 
 define Device/tl-wr1041n-v2
     $(Device/tplink-4mlzma)