ramips: rt288x: add support for the Buffalo WLI-TX4-AG300N board
authorGabor Juhos <juhosg@openwrt.org>
Tue, 27 Dec 2011 16:56:30 +0000 (16:56 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 27 Dec 2011 16:56:30 +0000 (16:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29612 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wli-tx4-ag300n.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt288x/config-2.6.39

index edb8376..652787b 100755 (executable)
@@ -66,6 +66,9 @@ get_status_led() {
        whr-g300n)
                status_led="whr-g300n:green:router"
                ;;
+       wli-tx4-ag300n)
+               status_led="buffalo:blue:power"
+               ;;
        wl-351)
                status_led="wl-351:amber:power"
                ;;
index a1d4887..55c577e 100644 (file)
@@ -60,6 +60,7 @@ case "$FIRMWARE" in
        wcr-150gn | \
        whr-g300n | \
        wl-351 | \
+       wli-tx4-ag300n | \
        wr512-3gn)
                rt2x00_eeprom_extract "factory" 0 272
                ;;
index 60dd716..834a2a7 100755 (executable)
@@ -30,6 +30,10 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "rtl8366rb" "2" "4 5t"
                ;;
 
+       wli-tx4-ag300n)
+               ucidef_set_interface_lan "eth0"
+               ;;
+
        rt-n15)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "rtl8366s" "1" "1"
@@ -81,6 +85,11 @@ ramips_setup_macs()
                 lan_mac=$(ramips_get_mac_binary factory 4)
                 wan_mac=$(ramips_get_mac_binary factory 40)
                ;;
+
+       wli-tx4-ag300n)
+               lan_mac=$(ramips_get_mac_binary factory 4)
+               ;;
+
        esac
 
        [ -n $lan_mac ] && ucidef_set_interface_macaddr lan $lan_mac
index 4dc10ae..d197fce 100755 (executable)
@@ -107,6 +107,9 @@ ramips_board_name() {
        *"Sitecom WL-351 v1 002")
                name="wl-351"
                ;;
+       *"WLI-TX4-AG300N")
+               name="wli-tx4-ag300n"
+               ;;
        *"WZR-AGL300NH")
                name="wzr-agl300nh"
                ;;
index 03a1e7b..aebaf38 100755 (executable)
@@ -27,6 +27,7 @@ platform_check_image() {
        rt-g32-b1 | \
        rt-n15 | \
        v22rw-2x2 | \
+       wli-tx4-ag300n | \
        whr-g300n)
                [ "$magic" != "2705" ] && {
                        echo "Invalid image type."
index 7129760..9e48b5c 100644 (file)
@@ -15,6 +15,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_GENERIC,
        /* RT2880 based machines */
        RAMIPS_MACH_RT_N15,             /* Asus RT-N15 */
+       RAMIPS_MACH_WLI_TX4_AG300N,     /* Buffalo WLI-TX4-AG300N */
        RAMIPS_MACH_WZR_AGL300NH,       /* Buffalo WZR-AGL300NH */
 
        /* RT3050 based machines */
index 0fc7788..c30b3ad 100644 (file)
@@ -7,6 +7,11 @@ config RT288X_MACH_RT_N15
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT288X_MACH_WLI_TX4_AG300N
+       bool "Buffalo WLI-TX4-AG300N board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT288X_MACH_WZR_AGL300NH
        bool "Buffalo WZR-AGL300NH board support"
        select RALINK_DEV_GPIO_LEDS
index 103081a..ab70701 100644 (file)
@@ -14,5 +14,5 @@ obj-y := irq.o setup.o rt288x.o devices.o clock.o
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
 obj-$(CONFIG_RT288X_MACH_RT_N15)       += mach-rt-n15.o
-
+obj-$(CONFIG_RT288X_MACH_WLI_TX4_AG300N) += mach-wli-tx4-ag300n.o
 obj-$(CONFIG_RT288X_MACH_WZR_AGL300NH) += mach-wzr-agl300nh.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wli-tx4-ag300n.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wli-tx4-ag300n.c
new file mode 100644 (file)
index 0000000..0f200ea
--- /dev/null
@@ -0,0 +1,154 @@
+/*
+ *  Buffalo WLI-TX4-AG300N board support
+ *
+ *  Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/ethtool.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_regs.h>
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#include "devices.h"
+
+#define WLI_TX4_AG300N_GPIO_LED_DIAG           10
+#define WLI_TX4_AG300N_GPIO_LED_POWER          12
+#define WLI_TX4_AG300N_GPIO_LED_SECURITY       13
+
+#define WLI_TX4_AG300N_GPIO_BUTTON_AOSS                0
+#define WLI_TX4_AG300N_GPIO_BUTTON_BW_SWITCH   8
+#define WLI_TX4_AG300N_GPIO_BUTTON_RESET       9
+
+#define WLI_TX4_AG300N_BUTTONS_POLL_INTERVAL   20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition wli_tx4_ag300n_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       },
+       {
+               .name   = "u-boot-env",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       },
+       {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       },
+       {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0d0000,
+       },
+       {
+               .name   = "rootfs",
+               .offset = 0x120000,
+               .size   = 0x2d0000,
+       },
+       {
+               .name   = "user",
+               .offset = 0x3f0000,
+               .size   = 0x010000,
+       },
+       {
+               .name   = "firmware",
+               .offset = 0x050000,
+               .size   = 0x3a0000,
+       },
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data wli_tx4_ag300n_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(wli_tx4_ag300n_partitions),
+       .parts          = wli_tx4_ag300n_partitions,
+#endif
+};
+
+static struct gpio_led wli_tx4_ag300n_leds_gpio[] __initdata = {
+       {
+               .name           = "buffalo:blue:power",
+               .gpio           = WLI_TX4_AG300N_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "buffalo:red:diag",
+               .gpio           = WLI_TX4_AG300N_GPIO_LED_DIAG,
+               .active_low     = 1,
+       },
+       {
+               .name           = "buffalo:blue:security",
+               .gpio           = WLI_TX4_AG300N_GPIO_LED_SECURITY,
+               .active_low     = 0,
+       },
+};
+
+static struct gpio_button wli_tx4_ag300n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = WLI_TX4_AG300N_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "AOSS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = WLI_TX4_AG300N_GPIO_BUTTON_AOSS,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "Bandwidth switch",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .threshold      = 3,
+               .gpio           = WLI_TX4_AG300N_GPIO_BUTTON_BW_SWITCH,
+               .active_low     = 0,
+       },
+};
+
+static void __init wli_tx4_ag300n_init(void)
+{
+       rt288x_gpio_init(RT2880_GPIO_MODE_UART0);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(wli_tx4_ag300n_leds_gpio),
+                                 wli_tx4_ag300n_leds_gpio);
+       ramips_register_gpio_buttons(-1, WLI_TX4_AG300N_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(wli_tx4_ag300n_gpio_buttons),
+                                    wli_tx4_ag300n_gpio_buttons);
+
+       rt288x_register_flash(0, &wli_tx4_ag300n_flash_data);
+       rt288x_register_wifi();
+       rt288x_register_wdt();
+
+       rt288x_eth_data.speed = SPEED_100;
+       rt288x_eth_data.duplex = DUPLEX_FULL;
+       rt288x_eth_data.tx_fc = 1;
+       rt288x_eth_data.rx_fc = 1;
+       rt288x_register_ethernet();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_WLI_TX4_AG300N, "WLI-TX4-AG300N",
+            "Buffalo WLI-TX4-AG300N", wli_tx4_ag300n_init);
index 8f4e211..a2845fd 100644 (file)
@@ -89,6 +89,10 @@ define BuildFirmware/Buffalo
        fi; fi
 endef
 
+define BuildFirmware/Buffalo2
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),$($(4)),$(5),$(6))
+endef
+
 define BuildFirmware/NW718
        $(call PatchKernelLzma,$(2),$(3) $($(4)))
        mkimage -A mips -O linux -T kernel -C lzma $(call kernel_entry) \
@@ -284,9 +288,15 @@ define Image/Build/Profile/RTN15
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
 endef
 
+mtdlayout_wlitx4ag300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
+define Image/Build/Profile/WLITX4AG300N
+       $(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,mtdlayout_wlitx4ag300n,851968,2949120)
+endef
+
 ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/RTN15,$(1))
+       $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef
 endif
 
index 3936c06..a5fead5 100644 (file)
@@ -93,6 +93,7 @@ CONFIG_RALINK_RT288X=y
 # CONFIG_RALINK_RT305X is not set
 CONFIG_RAMIPS_WDT=y
 CONFIG_RT288X_MACH_RT_N15=y
+CONFIG_RT288X_MACH_WLI_TX4_AG300N=y
 CONFIG_RT288X_MACH_WZR_AGL300NH=y
 CONFIG_RTL8366S_PHY=y
 CONFIG_RTL8366_SMI=y