kernel: add references to openwrt alternative button handling
authorJohn Crispin <blogic@openwrt.org>
Sat, 17 Jan 2015 07:07:28 +0000 (07:07 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sat, 17 Jan 2015 07:07:28 +0000 (07:07 +0000)
Add documentation that makes it easier to find the alternative,
recommended, and default handling for buttons in OpenWrt.

Signed-off-by: Karl Palsson <karlp@tweak.net.au>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43989 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/input.mk

index 32adc1e..f42cbae 100644 (file)
@@ -82,6 +82,9 @@ endef
 define KernelPackage/input-gpio-keys/description
  This driver implements support for buttons connected
  to GPIO pins of various CPUs (and some other chips).
 define KernelPackage/input-gpio-keys/description
  This driver implements support for buttons connected
  to GPIO pins of various CPUs (and some other chips).
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys))
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys))
@@ -101,6 +104,9 @@ endef
 
 define KernelPackage/input-gpio-keys-polled/description
  Kernel module for support polled GPIO keys input device
 
 define KernelPackage/input-gpio-keys-polled/description
  Kernel module for support polled GPIO keys input device
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys-polled))
 endef
 
 $(eval $(call KernelPackage,input-gpio-keys-polled))