ar71xx: added support for TL-WA830RE V2
authorJohn Crispin <blogic@openwrt.org>
Sun, 13 Jul 2014 07:12:22 +0000 (07:12 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sun, 13 Jul 2014 07:12:22 +0000 (07:12 +0000)
Corrected patch ath79 insted of auth79. Sorry.

Signed-off-by: Fredrik Jonson <fredrik@famjonson.se>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41596 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.10
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c [new file with mode: 0644]
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/mikrotik/config-default
target/linux/ar71xx/patches-3.10/714-MIPS-ath79-add-TL-WA830REv2-support.patch [new file with mode: 0644]

index ef172b4..d2e4937 100755 (executable)
@@ -184,6 +184,7 @@ get_status_led() {
        tl-wr841n-v1 | \
        tl-wr841n-v7 | \
        tl-wr841n-v8 | \
+       tl-wa830re-v2 | \
        tl-wr842n-v2 | \
        tl-wr941nd)
                status_led="tp-link:green:system"
index fe5ff93..ebc8942 100755 (executable)
@@ -286,6 +286,11 @@ tl-wr841n-v8)
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
        ;;
 
+tl-wa830re-v2)
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+       ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
+       ;;
+
 tl-wr841n-v9)
        ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
        ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
index 646425c..6a43d03 100755 (executable)
@@ -269,6 +269,7 @@ tl-mr3040 |\
 tl-mr3040-v2 |\
 tl-wa750re |\
 tl-wa850re |\
+tl-wa830re-v2 |\
 tl-wa801nd-v2 |\
 tl-wa901nd |\
 tl-wa901nd-v2 |\
index bd277ab..88a1c86 100755 (executable)
@@ -541,6 +541,9 @@ ar71xx_board_detect() {
        *TL-WA850RE)
                name="tl-wa850re"
                ;;
+       *"TL-WA830RE v2")
+               name="tl-wa830re-v2"
+               ;;
        *"TL-WA801ND v2")
                name="tl-wa801nd-v2"
                ;;
index 8af9580..8f3b563 100755 (executable)
@@ -253,6 +253,7 @@ platform_check_image() {
        tl-wr741nd | \
        tl-wr741nd-v4 | \
        tl-wr841n-v1 | \
+       tl-wa830re-v2 | \
        tl-wr841n-v7 | \
        tl-wr841n-v8 | \
        tl-wr841n-v9 | \
index 4e30a44..fbd22b9 100644 (file)
@@ -82,6 +82,7 @@ CONFIG_ATH79_MACH_TL_MR11U=y
 CONFIG_ATH79_MACH_TL_MR13U=y
 CONFIG_ATH79_MACH_TL_MR3020=y
 CONFIG_ATH79_MACH_TL_MR3X20=y
+CONFIG_ATH79_MACH_TL_WA830RE_V2=y
 CONFIG_ATH79_MACH_TL_WA901ND=y
 CONFIG_ATH79_MACH_TL_WA901ND_V2=y
 CONFIG_ATH79_MACH_TL_WAX50RE=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c
new file mode 100644 (file)
index 0000000..1c74fed
--- /dev/null
@@ -0,0 +1,132 @@
+/*
+ *  TP-LINK TL-WA830RE v2 board support
+ *
+ *  Copyright (C) 2014 Fredrik Jonson <fredrik@famjonson.se>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TL_WA830REV2_GPIO_LED_WLAN     13
+#define TL_WA830REV2_GPIO_LED_QSS      15
+#define TL_WA830REV2_GPIO_LED_LAN      18
+#define TL_WA830REV2_GPIO_LED_SYSTEM   14
+
+#define TL_WA830REV2_GPIO_BTN_RESET    17
+#define TL_WA830REV2_GPIO_SW_RFKILL    16      /* WPS for MR3420 v2 */
+
+#define TL_WA830REV2_GPIO_USB_POWER    4
+
+#define TL_WA830REV2_KEYS_POLL_INTERVAL        20      /* msecs */
+#define TL_WA830REV2_KEYS_DEBOUNCE_INTERVAL (3 * TL_WA830REV2_KEYS_POLL_INTERVAL)
+
+static const char *tl_wa830re_v2_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data tl_wa830re_v2_flash_data = {
+       .part_probes    = tl_wa830re_v2_part_probes,
+};
+
+static struct gpio_led tl_wa830re_v2_leds_gpio[] __initdata = {
+       {
+               .name           = "tp-link:green:qss",
+               .gpio           = TL_WA830REV2_GPIO_LED_QSS,
+               .active_low     = 1,
+       }, {
+               .name           = "tp-link:green:system",
+               .gpio           = TL_WA830REV2_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       }, {
+               .name           = "tp-link:green:lan",
+               .gpio           = TL_WA830REV2_GPIO_LED_LAN,
+               .active_low     = 1,
+       }, {
+               .name           = "tp-link:green:wlan",
+               .gpio           = TL_WA830REV2_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button tl_wa830re_v2_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TL_WA830REV2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WA830REV2_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "RFKILL switch",
+               .type           = EV_SW,
+               .code           = KEY_RFKILL,
+               .debounce_interval = TL_WA830REV2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WA830REV2_GPIO_SW_RFKILL,
+               .active_low     = 0,
+       }
+};
+
+static void __init tl_ap123_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       /* Disable JTAG, enabling GPIOs 0-3 */
+       /* Configure OBS4 line, for GPIO 4*/
+       ath79_gpio_function_setup(AR934X_GPIO_FUNC_JTAG_DISABLE,
+                                AR934X_GPIO_FUNC_CLK_OBS4_EN);
+
+       /* config gpio4 as normal gpio function */
+       ath79_gpio_output_select(TL_WA830REV2_GPIO_USB_POWER,
+                                AR934X_GPIO_OUT_GPIO);
+
+       ath79_register_m25p80(&tl_wa830re_v2_flash_data);
+
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_SW_PHY_SWAP);
+
+       ath79_register_mdio(1, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+
+       /* GMAC0 is connected to the PHY0 of the internal switch */
+       ath79_switch_data.phy4_mii_en = 1;
+       ath79_switch_data.phy_poll_mask = BIT(0);
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ath79_eth0_data.phy_mask = BIT(0);
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+       ath79_register_eth(0);
+
+       ath79_register_wmac(ee, mac);
+}
+
+static void __init tl_wa830re_v2_setup(void)
+{
+       tl_ap123_setup();
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_wa830re_v2_leds_gpio) - 1,
+                                tl_wa830re_v2_leds_gpio);
+
+       ath79_register_gpio_keys_polled(1, TL_WA830REV2_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(tl_wa830re_v2_gpio_keys),
+                                       tl_wa830re_v2_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WA830RE_V2, "TL-WA830RE-v2", "TP-LINK TL-WA830RE v2",
+            tl_wa830re_v2_setup);
index 6bc1105..4b5f502 100644 (file)
@@ -1149,6 +1149,7 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR741NV4,tl-wr741nd-v4,TL-WR741
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR743NV2,tl-wr743nd-v2,TL-WR741ND-v4,ttyATH0,115200,0x07430002,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA750,tl-wa750re-v1,TL-WA750RE,ttyS0,115200,0x07500001,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR841NV8,tl-wr841n-v8,TL-WR841N-v8,ttyS0,115200,0x08410008,1,4Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA830RV2,tl-wa830re-v2,TL-WA830RE-v2,ttyS0,115200,0x08300002,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR841NV9,tl-wr841n-v9,TL-WR841N-v9,ttyS0,115200,0x08410009,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR842V2,tl-wr842n-v2,TL-WR842N-v2,ttyS0,115200,0x8420002,1,8Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA801NV2,tl-wa801nd-v2,TL-WA801ND-v2,ttyS0,115200,0x08010002,1,4Mlzma))
@@ -1214,7 +1215,7 @@ $(eval $(call MultiProfile,TLMR3220,TLMR3220V1 TLMR3220V2))
 $(eval $(call MultiProfile,TLMR3420,TLMR3420V1 TLMR3420V2))
 $(eval $(call MultiProfile,TLWA730RE,TLWA730REV1))
 $(eval $(call MultiProfile,TLWA801,TLWA801NV1 TLWA801NV2))
-$(eval $(call MultiProfile,TLWA830,TLWA830RV1))
+$(eval $(call MultiProfile,TLWA830,TLWA830RV1 TLWA830RV2))
 $(eval $(call MultiProfile,TLWA901,TLWA901NV1 TLWA901NV2 TLWA901NV3))
 $(eval $(call MultiProfile,TLWA7510,TLWA7510NV1))
 $(eval $(call MultiProfile,TLWR720,TLWR720NV3))
index 39d3e60..8923015 100644 (file)
@@ -50,6 +50,7 @@ CONFIG_ATH79_MACH_RBSXTLITE=y
 # CONFIG_ATH79_MACH_TL_MR13U is not set
 # CONFIG_ATH79_MACH_TL_MR3020 is not set
 # CONFIG_ATH79_MACH_TL_MR3X20 is not set
+# CONFIG_ATH79_MACH_TL_WA830RE_V2 is not set
 # CONFIG_ATH79_MACH_TL_WA901ND is not set
 # CONFIG_ATH79_MACH_TL_WA901ND_V2 is not set
 # CONFIG_ATH79_MACH_TL_WDR3500 is not set
diff --git a/target/linux/ar71xx/patches-3.10/714-MIPS-ath79-add-TL-WA830REv2-support.patch b/target/linux/ar71xx/patches-3.10/714-MIPS-ath79-add-TL-WA830REv2-support.patch
new file mode 100644 (file)
index 0000000..fcb619c
--- /dev/null
@@ -0,0 +1,42 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -647,7 +647,17 @@ config ATH79_MACH_TL_WAX50RE
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+-
++
++config ATH79_MACH_TL_WA830RE_V2
++      bool "TP-LINK TL-WA830RE v2 support"
++      select SOC_AR934X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_WA901ND
+       bool "TP-LINK TL-WA901ND/TL-WA7510N support"
+       select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -95,6 +95,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR13U)    += mac
+ obj-$(CONFIG_ATH79_MACH_TL_MR3020)    += mach-tl-mr3020.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3X20)    += mach-tl-mr3x20.o
+ obj-$(CONFIG_ATH79_MACH_TL_WAX50RE)     += mach-tl-wax50re.o
++obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2)        += mach-tl-wa830re-v2.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2)        += mach-tl-wa901nd-v2.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR3500)     += mach-tl-wdr3500.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -112,6 +112,7 @@ enum ath79_mach_type {
+       ATH79_MACH_TL_WA7510N_V1,       /* TP-LINK TL-WA7510N v1*/
+       ATH79_MACH_TL_WA850RE,          /* TP-LINK TL-WA850RE */
+       ATH79_MACH_TL_WA801ND_V2,       /* TP-LINK TL-WA801ND v2 */
++      ATH79_MACH_TL_WA830RE_V2,       /* TP-LINK TL-WA830RE v2 */
+       ATH79_MACH_TL_WA901ND,          /* TP-LINK TL-WA901ND */
+       ATH79_MACH_TL_WA901ND_V2,       /* TP-LINK TL-WA901ND v2 */
+       ATH79_MACH_TL_WA901ND_V3,       /* TP-LINK TL-WA901ND v3
+