[ramips] D-Link DAP-1350 initial support
authorJohn Crispin <blogic@openwrt.org>
Tue, 24 Jul 2012 20:38:43 +0000 (20:38 +0000)
committerJohn Crispin <blogic@openwrt.org>
Tue, 24 Jul 2012 20:38:43 +0000 (20:38 +0000)
The initial support for the D-Link DAP-1350.
USB related functionality is not tested.

Signed-off-by: Yoichi Shinoda <shinoda@jaist.ac.jp>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32821 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dap-1350.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.3

index 68aa0ee..c1f5949 100755 (executable)
@@ -39,6 +39,9 @@ get_status_led() {
        dir-300-b1 | dir-600-b1 | dir-600-b2)
                status_led="d-link:green:status"
                ;;
+       dap-1350)
+               status_led="d-link:blue:power"
+               ;;
        esr-9753)
                status_led="esr-9753:orange:power"
                ;;
index 841aac4..d293357 100644 (file)
@@ -38,6 +38,10 @@ case "$FIRMWARE" in
                rt2x00_eeprom_extract "devdata" 16384 272
                ;;
 
+       dap-1350)
+               rt2x00_eeprom_extract "devdata" 0 272
+               ;;
+
        rt-n10-plus | \
        rt-g32-b1)
                rt2x00_eeprom_extract "devconf" 0 272
index 126c475..f701b7e 100644 (file)
@@ -29,6 +29,10 @@ preinit_set_mac_address() {
                 mac=$(ramips_get_mac_binary devdata 16388)
                 ifconfig eth0 hw ether $mac 2>/dev/null
                 ;;
+       dap-1350)
+               mac=$(ramips_get_mac_binary devdata 46)
+               ifconfig eth0 hw ether $mac 2>/dev/null
+                ;;
        all0256n |\
        all5002 | \
        fonera20n |\
index 2667267..0089e0d 100755 (executable)
@@ -80,6 +80,9 @@ ramips_board_name() {
        *"DIR-600 B2")
                name="dir-600-b2"
                ;;
+        *"DAP-1350")
+                name="dap-1350"
+                ;;
        *"ESR-9753")
                name="esr-9753"
                ;;
index 2791c8d..eb9a0d1 100755 (executable)
@@ -21,6 +21,7 @@ platform_check_image() {
        dir-300-b1 | \
        dir-600-b1 | \
        dir-600-b2 | \
+       dap-1350 | \
        esr-9753 | \
        fonera20n | \
        freestation5 | \
index 7741eac..50f8688 100644 (file)
@@ -36,6 +36,7 @@ enum ramips_mach_type {
        /* RT3052 based machines */
        RAMIPS_MACH_ARGUS_ATP52B,       /* Argus ATP-52B */
        RAMIPS_MACH_BC2,                /* NexAira BC2 */
+       RAMIPS_MACH_DAP_1350,           /* D-Link DAP-1350 */
        RAMIPS_MACH_ESR_9753,           /* Senao / EnGenius ESR-9753*/
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
index 34fb51a..48745ae 100644 (file)
@@ -71,6 +71,11 @@ config RT305X_MACH_DIR_300_REVB
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_DAP_1350
+       bool "D-Link DAP-1350 board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_ESR_9753
        bool "EnGenius ESR-9753 support"
        select RALINK_DEV_GPIO_BUTTONS
index 7a6fcc0..e5035e2 100644 (file)
@@ -17,6 +17,7 @@ obj-$(CONFIG_RT305X_MACH_BC2)         += mach-bc2.o
 obj-$(CONFIG_RT305X_MACH_ALL0256N)     += mach-all0256n.o
 obj-$(CONFIG_RT305X_MACH_ALL5002)      += mach-all5002.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
+obj-$(CONFIG_RT305X_MACH_DAP_1350)     += mach-dap-1350.o
 obj-$(CONFIG_RT305X_MACH_ESR_9753)     += mach-esr-9753.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dap-1350.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dap-1350.c
new file mode 100644 (file)
index 0000000..cd5d6ae
--- /dev/null
@@ -0,0 +1,94 @@
+/*
+ *  D-Link DAP-1350 board support
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define DAP_1350_GPIO_LED_POWER_BLUE   8
+#define DAP_1350_GPIO_LED_POWER_RED    9
+#define DAP_1350_GPIO_LED_WPS          14
+
+#define DAP_1350_GPIO_BUTTON_WPS       0       /* active low */
+#define DAP_1350_GPIO_BUTTON_RESET     10      /* active low */
+#define DAP_1350_GPIO_SWITCH_MODE_AP   7       /* active low */
+#define DAP_1350_GPIO_SWITCH_MODE_RT   11      /* active low */
+
+#define DAP_1350_KEYS_POLL_INTERVAL    20
+#define DAP_1350_KEYS_DEBOUNCE_INTERVAL        (3 * DAP_1350_KEYS_POLL_INTERVAL)
+
+static struct gpio_led dap_1350_leds_gpio[] __initdata = {
+       {
+               .name           = "d-link:blue:power",
+               .gpio           = DAP_1350_GPIO_LED_POWER_BLUE,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:red:power",
+               .gpio           = DAP_1350_GPIO_LED_POWER_RED,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:blue:wps",
+               .gpio           = DAP_1350_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button dap_1350_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = DAP_1350_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DAP_1350_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = DAP_1350_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DAP_1350_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }, {
+               .desc           = "rt",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .debounce_interval = DAP_1350_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DAP_1350_GPIO_SWITCH_MODE_RT,
+               .active_low     = 1,
+       }, {
+               .desc           = "ap",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .debounce_interval = DAP_1350_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DAP_1350_GPIO_SWITCH_MODE_AP,
+               .active_low     = 1,
+       }
+};
+
+static void __init dap_1350_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(dap_1350_leds_gpio),
+                                 dap_1350_leds_gpio);
+       ramips_register_gpio_buttons(-1, DAP_1350_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(dap_1350_gpio_buttons),
+                                    dap_1350_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_DAP_1350, "DAP-1350", "D-Link DAP-1350",
+            dap_1350_init);
index 6aa03a3..5675201 100644 (file)
@@ -182,6 +182,20 @@ define BuildFirmware/DIR300B1/initramfs
        $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
 endef
 
+mtdlayout_dap1350=192k(u-boot)ro,64k(devdata)ro,192k(devconf)ro,256k(devlang)ro,1088k(kernel),6400k(rootfs),7488k@0xb0000(firmware)
+mtd_dap1350_kernel_part_size=1114112
+mtd_dap1350_rootfs_part_size=6553600
+define BuildFirmware/DAP1350
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),ttyS1,115200) $(call mkmtd/phys,$(mtdlayout_dap1350)),$(mtd_dap1350_kernel_part_size),$(mtd_dap1350_rootfs_part_size))
+       mkdapimg -s $(4) \
+               -i $(call sysupname,$(1),$(2)) \
+               -o $(call imgname,$(1),$(2))-factory.bin
+endef
+
+define BuildFirmware/DAP1350/initramfs
+       $(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),ttyS1,115200) $(call mkmtd/phys,$(mtdlayout_dap1350)),$(mtd_dap1350_kernel_part_size),$(mtd_dap1350_rootfs_part_size))
+endef
+
 define BuildFirmware/Edimax
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
                mkedimaximg -i $(call sysupname,$(1),$(2)) \
@@ -353,6 +367,10 @@ define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/$(fs_squash)/$(1),DIR300B1,dir-615-d,DIR-615-D,wrgn23_dlwbr_dir615d)
 endef
 
+define Image/Build/Profile/DAP1350
+       $(call Image/Build/Template/$(fs_squash)/$(1),DAP1350,dap-1350,DAP-1350,RT3052-AP-DAP1350-3)
+endef
+
 define Image/Build/Profile/ESR9753
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,esr-9753,ESR-9753,ttyS1,57600,phys)
 endef
@@ -472,6 +490,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
+       $(call Image/Build/Profile/DAP1350,$(1))
        $(call Image/Build/Profile/ESR9753,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/RTN10PLUS,$(1))
index 79820a8..04afff6 100644 (file)
@@ -93,6 +93,7 @@ CONFIG_RT305X_MACH_ALL5002=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y
 CONFIG_RT305X_MACH_BC2=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
+CONFIG_RT305X_MACH_DAP_1350=y
 CONFIG_RT305X_MACH_ESR_9753=y
 CONFIG_RT305X_MACH_F5D8235_V2=y
 CONFIG_RT305X_MACH_FONERA20N=y