CC: kernel: update 3.18 to 3.18.19
authorJonas Gorski <jogo@openwrt.org>
Sat, 25 Jul 2015 10:02:47 +0000 (10:02 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 25 Jul 2015 10:02:47 +0000 (10:02 +0000)
Changelog:
 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.19

Backport of r46439.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46487 3c298f89-4303-0410-b956-a3cf2f4a3e73

12 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-3.18/718-MIPS-ath79-add-EPG5000-support.patch
target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
target/linux/ar71xx/patches-3.18/736-MIPS-ath79-add-MC-MAC1200R-support.patch
target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
target/linux/ar71xx/patches-3.18/738-MIPS-ath79-add-meraki-mr12-mr16-support.patch
target/linux/ar71xx/patches-3.18/800-MIPS-ath79-add-RB922GS-support.patch
target/linux/ar71xx/patches-3.18/903-MIPS-ath79-ubnt-rocket-m-xw-support.patch
target/linux/ar71xx/patches-3.18/905-MIPS-ath79-bitmain-antminer-s3-support.patch
target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch

index 4306dfa..1944597 100644 (file)
@@ -2,9 +2,9 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .18
+LINUX_VERSION-3.18 = .19
 
 
-LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
+LINUX_KERNEL_MD5SUM-3.18.19 = a143f9421bd8413752609d0d771c2955
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index d50081a..bac8f20 100644 (file)
  
  config ATH79_MACH_UBNT_XM
        bool "Ubiquiti Networks XM/UniFi boards"
  
  config ATH79_MACH_UBNT_XM
        bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1116,97 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1105,97 @@ config ATH79_MACH_UBNT_XM
          Say 'Y' here if you want your kernel to support the
          Ubiquiti Networks XM (rev 1.0) board.
  
          Say 'Y' here if you want your kernel to support the
          Ubiquiti Networks XM (rev 1.0) board.
  
  endmenu
  
  config SOC_AR71XX
  endmenu
  
  config SOC_AR71XX
-@@ -124,7 +1248,10 @@ config ATH79_DEV_DSA
+@@ -124,7 +1237,10 @@ config ATH79_DEV_DSA
  config ATH79_DEV_ETH
        def_bool n
  
  config ATH79_DEV_ETH
        def_bool n
  
        def_bool n
  
  config ATH79_DEV_GPIO_BUTTONS
        def_bool n
  
  config ATH79_DEV_GPIO_BUTTONS
-@@ -154,6 +1281,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -154,6 +1270,11 @@ config ATH79_PCI_ATH9K_FIXUP
        def_bool n
  
  config ATH79_ROUTERBOOT
        def_bool n
  
  config ATH79_ROUTERBOOT
index 4f5d203..a24d496 100644 (file)
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1194,6 +1194,10 @@ config SOC_AR934X
+@@ -1218,6 +1218,10 @@ config SOC_AR934X
        select PCI_AR724X if PCI
        def_bool n
  
        select PCI_AR724X if PCI
        def_bool n
  
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
-@@ -1236,7 +1240,7 @@ config ATH79_DEV_USB
+@@ -1260,7 +1264,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
        def_bool n
  
  config ATH79_DEV_WMAC
index 579e024..23e7a26 100644 (file)
@@ -19,7 +19,7 @@
        select SOC_QCA955X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
        select SOC_QCA955X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -69,6 +69,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2)    += mach-eap300v2.o
+@@ -71,6 +71,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2)    += mac
  obj-$(CONFIG_ATH79_MACH_EAP7660D)     += mach-eap7660d.o
  obj-$(CONFIG_ATH79_MACH_EL_M150)      += mach-el-m150.o
  obj-$(CONFIG_ATH79_MACH_EL_MINI)      += mach-el-mini.o
  obj-$(CONFIG_ATH79_MACH_EAP7660D)     += mach-eap7660d.o
  obj-$(CONFIG_ATH79_MACH_EL_M150)      += mach-el-m150.o
  obj-$(CONFIG_ATH79_MACH_EL_MINI)      += mach-el-mini.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_GL_INET)      += mach-gl-inet.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
  obj-$(CONFIG_ATH79_MACH_GL_INET)      += mach-gl-inet.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -59,6 +59,7 @@ enum ath79_mach_type {
+@@ -61,6 +61,7 @@ enum ath79_mach_type {
        ATH79_MACH_EL_M150,             /* EasyLink EL-M150 */
        ATH79_MACH_EL_MINI,             /* EasyLink EL-MINI */
        ATH79_MACH_ESR1750,             /* EnGenius ESR1750 */
        ATH79_MACH_EL_M150,             /* EasyLink EL-M150 */
        ATH79_MACH_EL_MINI,             /* EasyLink EL-MINI */
        ATH79_MACH_ESR1750,             /* EnGenius ESR1750 */
index f95fc0b..90c9b33 100644 (file)
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1203,6 +1203,12 @@ config SOC_QCA955X
+@@ -1237,6 +1237,12 @@ config SOC_QCA955X
        select PCI_AR724X if PCI
        def_bool n
  
        select PCI_AR724X if PCI
        def_bool n
  
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
-@@ -1240,7 +1246,7 @@ config ATH79_DEV_USB
+@@ -1274,7 +1280,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
        def_bool n
  
  config ATH79_DEV_WMAC
index 8789fef..e22c26f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -544,6 +544,16 @@ config ATH79_MACH_R6100
+@@ -578,6 +578,16 @@ config ATH79_MACH_R6100
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
@@ -19,7 +19,7 @@
        select SOC_AR71XX
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
        select SOC_AR71XX
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -77,6 +77,7 @@ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361)       +
+@@ -80,6 +80,7 @@ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361)       +
  obj-$(CONFIG_ATH79_MACH_JA76PF)               += mach-ja76pf.o
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
  obj-$(CONFIG_ATH79_MACH_JA76PF)               += mach-ja76pf.o
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -116,6 +116,7 @@ enum ath79_mach_type {
+@@ -119,6 +119,7 @@ enum ath79_mach_type {
        ATH79_MACH_TEW_673GRU,          /* TRENDnet TEW-673GRU */
        ATH79_MACH_TEW_712BR,           /* TRENDnet TEW-712BR */
        ATH79_MACH_TEW_732BR,           /* TRENDnet TEW-732BR */
        ATH79_MACH_TEW_673GRU,          /* TRENDnet TEW-673GRU */
        ATH79_MACH_TEW_712BR,           /* TRENDnet TEW-712BR */
        ATH79_MACH_TEW_732BR,           /* TRENDnet TEW-732BR */
index 39f5654..a8ee6f6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -83,6 +83,7 @@ enum ath79_mach_type {
+@@ -86,6 +86,7 @@ enum ath79_mach_type {
        ATH79_MACH_OM2P_LC,             /* OpenMesh OM2P-LC */
        ATH79_MACH_OM2Pv2,              /* OpenMesh OM2Pv2 */
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
        ATH79_MACH_OM2P_LC,             /* OpenMesh OM2P-LC */
        ATH79_MACH_OM2Pv2,              /* OpenMesh OM2Pv2 */
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
@@ -10,7 +10,7 @@
        ATH79_MACH_PB92,                /* Atheros PB92 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
        ATH79_MACH_PB92,                /* Atheros PB92 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -697,6 +697,7 @@ config ATH79_MACH_OM2P
+@@ -731,6 +731,7 @@ config ATH79_MACH_OM2P
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
index 4f3cd44..22e9b94 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -704,6 +704,26 @@ config ATH79_MACH_OM5P
+@@ -738,6 +738,26 @@ config ATH79_MACH_OM5P
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
@@ -29,7 +29,7 @@
        select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
        select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -78,6 +78,8 @@ obj-$(CONFIG_ATH79_MACH_JA76PF)              += mach
+@@ -81,6 +81,8 @@ obj-$(CONFIG_ATH79_MACH_JA76PF)              += mach
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
  obj-$(CONFIG_ATH79_MACH_MC_MAC1200R)     += mach-mc-mac1200r.o
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
  obj-$(CONFIG_ATH79_MACH_MC_MAC1200R)     += mach-mc-mac1200r.o
@@ -40,7 +40,7 @@
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -67,6 +67,8 @@ enum ath79_mach_type {
+@@ -70,6 +70,8 @@ enum ath79_mach_type {
        ATH79_MACH_JA76PF2,             /* jjPlus JA76PF2 */
        ATH79_MACH_JWAP003,             /* jjPlus JWAP003 */
        ATH79_MACH_HORNET_UB,           /* ALFA Networks Hornet-UB */
        ATH79_MACH_JA76PF2,             /* jjPlus JA76PF2 */
        ATH79_MACH_JWAP003,             /* jjPlus JWAP003 */
        ATH79_MACH_HORNET_UB,           /* ALFA Networks Hornet-UB */
index 133d0f7..a08a30f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -579,6 +579,16 @@ config ATH79_MACH_RB91X
+@@ -613,6 +613,16 @@ config ATH79_MACH_RB91X
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
@@ -19,7 +19,7 @@
         select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
         select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -98,6 +98,7 @@ obj-$(CONFIG_ATH79_MACH_R6100)               += mach-
+@@ -101,6 +101,7 @@ obj-$(CONFIG_ATH79_MACH_R6100)             += mach-
  obj-$(CONFIG_ATH79_MACH_RB4XX)                += mach-rb4xx.o
  obj-$(CONFIG_ATH79_MACH_RB750)                += mach-rb750.o
  obj-$(CONFIG_ATH79_MACH_RB91X)                += mach-rb91x.o
  obj-$(CONFIG_ATH79_MACH_RB4XX)                += mach-rb4xx.o
  obj-$(CONFIG_ATH79_MACH_RB750)                += mach-rb750.o
  obj-$(CONFIG_ATH79_MACH_RB91X)                += mach-rb91x.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_RBSXTLITE)    += mach-rbsxtlite.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
  obj-$(CONFIG_ATH79_MACH_RBSXTLITE)    += mach-rbsxtlite.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -105,6 +105,7 @@ enum ath79_mach_type {
+@@ -108,6 +108,7 @@ enum ath79_mach_type {
        ATH79_MACH_RB_750G_R3,          /* MikroTik RouterBOARD 750GL */
        ATH79_MACH_RB_751,              /* MikroTik RouterBOARD 751 */
        ATH79_MACH_RB_751G,             /* Mikrotik RouterBOARD 751G */
        ATH79_MACH_RB_750G_R3,          /* MikroTik RouterBOARD 750GL */
        ATH79_MACH_RB_751,              /* MikroTik RouterBOARD 751 */
        ATH79_MACH_RB_751G,             /* Mikrotik RouterBOARD 751G */
index f1c4d60..7fdefd6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -171,6 +171,7 @@ enum ath79_mach_type {
+@@ -174,6 +174,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
index 13dac2e..16d4405 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-3.18.18/arch/mips/ath79/Kconfig
-===================================================================
---- linux-3.18.18.orig/arch/mips/ath79/Kconfig
-+++ linux-3.18.18/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
 @@ -66,6 +66,16 @@ config ATH79_MACH_ANTMINER_S1
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
 @@ -66,6 +66,16 @@ config ATH79_MACH_ANTMINER_S1
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
@@ -19,10 +17,8 @@ Index: linux-3.18.18/arch/mips/ath79/Kconfig
  config ATH79_MACH_AP113
        bool "Atheros AP113 board support"
        select SOC_AR724X
  config ATH79_MACH_AP113
        bool "Atheros AP113 board support"
        select SOC_AR724X
-Index: linux-3.18.18/arch/mips/ath79/Makefile
-===================================================================
---- linux-3.18.18.orig/arch/mips/ath79/Makefile
-+++ linux-3.18.18/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
 @@ -43,6 +43,7 @@ obj-$(CONFIG_ATH79_MACH_ALFA_NX)     += mach
  obj-$(CONFIG_ATH79_MACH_ALL0258N)     += mach-all0258n.o
  obj-$(CONFIG_ATH79_MACH_ALL0315N)     += mach-all0315n.o
 @@ -43,6 +43,7 @@ obj-$(CONFIG_ATH79_MACH_ALFA_NX)     += mach
  obj-$(CONFIG_ATH79_MACH_ALL0258N)     += mach-all0258n.o
  obj-$(CONFIG_ATH79_MACH_ALL0315N)     += mach-all0315n.o
@@ -31,10 +27,8 @@ Index: linux-3.18.18/arch/mips/ath79/Makefile
  obj-$(CONFIG_ATH79_MACH_AP113)                += mach-ap113.o
  obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o
  obj-$(CONFIG_ATH79_MACH_AP132)                += mach-ap132.o
  obj-$(CONFIG_ATH79_MACH_AP113)                += mach-ap113.o
  obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o
  obj-$(CONFIG_ATH79_MACH_AP132)                += mach-ap132.o
-Index: linux-3.18.18/arch/mips/ath79/machtypes.h
-===================================================================
---- linux-3.18.18.orig/arch/mips/ath79/machtypes.h
-+++ linux-3.18.18/arch/mips/ath79/machtypes.h
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
 @@ -22,6 +22,7 @@ enum ath79_mach_type {
        ATH79_MACH_ALL0305,             /* Allnet ALL0305 */
        ATH79_MACH_ALL0315N,            /* Allnet ALL0315N */
 @@ -22,6 +22,7 @@ enum ath79_mach_type {
        ATH79_MACH_ALL0305,             /* Allnet ALL0305 */
        ATH79_MACH_ALL0315N,            /* Allnet ALL0315N */
index f9ca7eb..d49af48 100644 (file)
@@ -5,7 +5,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 ---
 --- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
 +++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
 ---
 --- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
 +++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-@@ -123,6 +123,12 @@
+@@ -143,6 +143,12 @@
                #address-cells = <1>;
                #size-cells = <0>;
  
                #address-cells = <1>;
                #size-cells = <0>;