CC: ca-certificages: Add certificate bundle for packages that need it
authorDaniel Dickinson <openwrt@daniel.thecshore.com>
Wed, 6 Jul 2016 07:32:25 +0000 (03:32 -0400)
committerZoltan HERPAI <wigyori@uid0.hu>
Sat, 4 Nov 2017 22:00:59 +0000 (23:00 +0100)
Some packages don't use /etc/ssl/certs but instead use /etc/ssl/certs/ca-certificates.crt.
For those packages add a ca-bundle package>.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
package/system/ca-certificates/Makefile

index 9b6dbd6..8590952 100644 (file)
@@ -26,6 +26,13 @@ define Package/ca-certificates
   PKGARCH:=all
 endef
 
+define Package/ca-bundle
+  SECTION:=base
+  CATEGORY:=Base system
+  TITLE:=System CA certificates as a bundle
+  PKGARCH:=all
+endef
+
 define Build/Install
        mkdir -p \
                $(PKG_INSTALL_DIR)/usr/sbin \
@@ -47,4 +54,9 @@ define Package/ca-certificates/install
        done
 endef
 
+define Package/ca-bundle/install
+       $(INSTALL_DIR) $(1)/etc/ssl/certs
+       cat $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt >$(1)/etc/ssl/certs/ca-certificates.crt
+endef
 $(eval $(call BuildPackage,ca-certificates))
+$(eval $(call BuildPackage,ca-bundle))