base-files: taint the build if the override mechanism is used
authorJohn Crispin <blogic@openwrt.org>
Mon, 9 Feb 2015 12:10:07 +0000 (12:10 +0000)
committerJohn Crispin <blogic@openwrt.org>
Mon, 9 Feb 2015 12:10:07 +0000 (12:10 +0000)
If some packages are overridden (using ./scripts/feeds -f), add a new
taint flag in /etc/openwrt_release. We'll use the CONFIG_OVERRIDE_PKGS
variable reported through the .config to detect it.

Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44337 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/version.mk

index c3cc170..99af96e 100644 (file)
@@ -58,6 +58,7 @@ VERSION_TAINT_SPECS := \
        +USE_EGLIBC:eglibc \
        +USE_MKLIBS:mklibs \
        +BUSYBOX_CUSTOM:busybox \
+       +OVERRIDE_PKGS:override \
 
 VERSION_TAINTS := $(strip $(foreach taint,$(VERSION_TAINT_SPECS), \
        $(if $(findstring +,$(taint)), \