use default_subtargets in package/Makefile and target/Makefile
authorFelix Fietkau <nbd@openwrt.org>
Mon, 26 Feb 2007 00:41:53 +0000 (00:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 26 Feb 2007 00:41:53 +0000 (00:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6380 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
target/Makefile

index 6ddbc1b..151942d 100644 (file)
@@ -22,20 +22,7 @@ $(STAMP_DIR) $(TARGET_DIR):
 %-prereq: $(STAMP_DIR) $(TARGET_DIR)
        $(MAKE) -C $(patsubst %-prereq,%,$@) prereq
 
-%-download: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-
-%-compile: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-
-%-install: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
-%-clean: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
+$(eval $(call default_subtargets,$(TARGET_DIR)))
 
 ifeq ($(SDK),1)
 GENDEP_OPTS := -s
index 724ac44..1b6cbb5 100644 (file)
@@ -51,14 +51,4 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
+$(eval $(call default_subtargets,))