ramips: add MPR-A1 support
authorJohn Crispin <blogic@openwrt.org>
Sat, 27 Jul 2013 09:23:52 +0000 (09:23 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sat, 27 Jul 2013 09:23:52 +0000 (09:23 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37568 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/01_leds
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/MPRA1.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/hame.mk

index cc426b7..f8e9787 100755 (executable)
@@ -55,6 +55,9 @@ get_status_led() {
        mofi3500-3gn)
                status_led="mofi3500-3gn:green:status"
                ;;
+       mpr-a1)
+               status_led="mpr-a1:red:power"
+               ;;
        mpr-a2)
                status_led="mpr-a2:red:power"
                ;;
index b3ca002..9e9e09b 100644 (file)
@@ -78,6 +78,7 @@ case "$FIRMWARE" in
        freestation5 | \
        hw550-3g | \
        mofi3500-3gn | \
+       mpr-a1 | \
        mpr-a2 | \
        pwh2004 | \
        nbg-419n | \
index 036d311..7f69231 100755 (executable)
@@ -94,6 +94,9 @@ case $board in
        mofi3500-3gn)
                set_usb_led "mofi3500-3gn:green:usb"
                ;;
+       mpr-a1)
+               set_wifi_led "mpr-a1:blue:system"
+               ;;
        mpr-a2)
                set_wifi_led "mpr-a2:blue:system"
                ;;
index 2d833b3..6877588 100755 (executable)
@@ -173,6 +173,7 @@ ramips_setup_macs()
        broadway | \
        dir-620-d1 | \
        f5d8235-v1 | \
+       mpr-a1 | \
        mpr-a2 | \
        mzk-w300nh2 | \
        nw718 | \
index 6f153aa..aacec25 100644 (file)
@@ -26,6 +26,7 @@ preinit_set_mac_address() {
        dir-620-a1 |\
        esr-9753 |\
        freestation5 |\
+       mpr-a1 | \
        mpr-a2 | \
        nw718 |\
        psr-680w |\
index cb6c10f..b1ecc8d 100755 (executable)
@@ -118,6 +118,9 @@ ramips_board_detect() {
        *"MoFi Network MOFI3500-3GN")
                name="mofi3500-3gn"
                ;;
+       *"HAME MPR-A1")
+               name="mpr-a1"
+               ;;
        *"HAME MPR-A2")
                name="mpr-a2"
                ;;
index ef2aa99..1d867a7 100755 (executable)
@@ -45,6 +45,7 @@ platform_check_image() {
        hw550-3g | \
        hg255d | \
        mofi3500-3gn | \
+       mpr-a1 | \
        mpr-a2 | \
        mzk-w300nh2 | \
        nbg-419n | \
diff --git a/target/linux/ramips/dts/MPRA1.dts b/target/linux/ramips/dts/MPRA1.dts
new file mode 100644 (file)
index 0000000..44363ef
--- /dev/null
@@ -0,0 +1,117 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "MPRA1", "ralink,rt5350-soc";
+       model = "HAME MPR-A1";
+
+       palmbus@10000000 {
+               sysc@0 {
+                       ralink,pinmux = "spi", "uartlite", "sdram";
+                       ralink,gpiomux = "jtag", "i2c", "mdio", "rgmii";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "s25fl064k";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "s25fl064k";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               status = "okay";
+       };
+
+       esw@10110000 {
+               status = "okay";
+               ralink,portmap = <0x2f>;
+       };
+
+       wmac@10180000 {
+               status = "okay";
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               system {
+                       label = "mpr-a1:blue:system";
+                       gpios = <&gpio0 20 1>;
+               };
+               power {
+                       label = "mpr-a1:red:power";
+                       gpios = <&gpio0 17 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               wps {
+                       label = "reset";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               usb {
+                       gpio-export,name = "usb";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 7 0>;
+               };
+               root_hub {
+                       gpio-export,name = "root_hub";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 12 0>;
+               };
+       };
+};
index 3ddf726..04d68fe 100644 (file)
@@ -341,6 +341,7 @@ Image/Build/Profile/FREESTATION5=$(call BuildFirmware/Default8M/$(1),$(1),freest
 Image/Build/Profile/MOFI3500-3GN=$(call BuildFirmware/Default8M/$(1),$(1),mofi3500-3gn,MOFI3500-3GN)
 
 # Kernel name should be "Linux Kernel Image" to make the OpenWrt image installable from factory Web UI
+Image/Build/Profile/MPRA1=$(call BuildFirmware/Default4M/$(1),$(1),mpr-a1,MPRA1,Linux Kernel Image)
 Image/Build/Profile/MPRA2=$(call BuildFirmware/Default8M/$(1),$(1),mpr-a2,MPRA2,Linux Kernel Image)
 
 Image/Build/Profile/NBG-419N=$(call BuildFirmware/Default4M/$(1),$(1),nbg-419n,NBG-419N)
index 1a85be7..3a60711 100644 (file)
@@ -5,6 +5,18 @@
 # See /LICENSE for more information.
 #
 
+define Profile/MPRA1
+       NAME:=HAME MPR-A1
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-net
+endef
+
+define Profile/MPRA1/Description
+       Package set for HAME MPR-A1 board
+endef
+
+$(eval $(call Profile,MPRA1))
+
 define Profile/MPRA2
        NAME:=HAME MPR-A2
        PACKAGES:=\