kernel: package the HW random core module
authorFlorian Fainelli <florian@openwrt.org>
Wed, 10 Jul 2013 19:42:48 +0000 (19:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 10 Jul 2013 19:42:48 +0000 (19:42 +0000)
And update the crypto-hw-hifn-795x to use it.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37231 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk
package/kernel/linux/modules/other.mk

index be76f53..065ddbf 100644 (file)
@@ -164,8 +164,8 @@ $(eval $(call KernelPackage,crypto-hw-geode))
 
 define KernelPackage/crypto-hw-hifn-795x
   TITLE:=HIFN 795x crypto accelerator
+  DEPENDS:=+kmod-random-core
   KCONFIG:= \
-       CONFIG_HW_RANDOM=y \
        CONFIG_CRYPTO_DEV_HIFN_795X \
        CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
   FILES:=$(LINUX_DIR)/drivers/crypto/hifn_795x.ko
index 387090a..94bf5dd 100644 (file)
@@ -684,3 +684,17 @@ define KernelPacakge/ptp-gianfar/description
 endef
 
 $(eval $(call KernelPackage,ptp-gianfar))
+
+define KernelPackage/random-core
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Hardware Random Number Generator Core support
+  KCONFIG:=CONFIG_HW_RANDOM
+  FILES:=$(LINUX_DIR)/drivers/char/hw_random/rng-core.ko
+  AUTOLOAD:=$(call AutoLoad,10,rng-core)
+endef
+
+define KernelPackage/random-core/description
+   Kernel module for the HW random number generator core infrastructure
+endef
+
+$(eval $(call KernelPackage,random-core))