ar71x: Added support for TP-Link TL-WR841N v11 to 15.05
authorJohn Crispin <blogic@openwrt.org>
Mon, 25 Apr 2016 20:08:54 +0000 (20:08 +0000)
committerJohn Crispin <blogic@openwrt.org>
Mon, 25 Apr 2016 20:08:54 +0000 (20:08 +0000)
This patch adds support for the TP-Link TL-WR841N to OpenWrt Chaos Calmer
15.05. Confirmed working [1] and [2].

Signed-off by Stijn Segers <francesco.borromini@inventati.org>

[1] https://forum.openwrt.org/viewtopic.php?id=63657
[2] https://forum.openwrt.org/viewtopic.php?id=61309

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49228 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 486ec3a..85a1857 100644 (file)
@@ -576,6 +576,13 @@ define Device/tl-wr841-v10
     TPLINK_HWID := 0x08410010
 endef
 
+define Device/tl-wr841-v11
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR841N-v9
+    DEVICE_PROFILE := TLWR841
+    TPLINK_HWID := 0x08410011
+endef
+
 define Device/tl-wr842n-v2
     $(Device/tplink-8mlzma)
     BOARDNAME := TL-WR842N-v2
@@ -596,7 +603,7 @@ define Device/tl-wr847n-v8
     DEVICE_PROFILE := TLWR841
     TPLINK_HWID := 0x08470008
 endef
-TARGET_DEVICES += tl-wr841-v8 tl-wr841-v9 tl-wr841-v10 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841-v8 tl-wr841-v9 tl-wr841-v10 tl-wr841-v11 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
 
 define Device/tl-wr941nd-v5
     $(Device/tplink-4mlzma)