kernel: make hwmon-lm75 only depend on kmod-thermal if needed
authorHauke Mehrtens <hauke@openwrt.org>
Sun, 14 Sep 2014 12:06:38 +0000 (12:06 +0000)
committerHauke Mehrtens <hauke@openwrt.org>
Sun, 14 Sep 2014 12:06:38 +0000 (12:06 +0000)
This fixes commit r42529 and closes #17855.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42531 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index 90f2197..ad0ef2d 100644 (file)
@@ -119,7 +119,7 @@ define KernelPackage/hwmon-lm75
   KCONFIG:=CONFIG_SENSORS_LM75
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
   AUTOLOAD:=$(call AutoProbe,lm75)
-  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
 endef
 
 define KernelPackage/hwmon-lm75/description