kernel: bump to 3.18.84
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 25 Nov 2017 12:39:20 +0000 (13:39 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Sat, 25 Nov 2017 23:03:48 +0000 (00:03 +0100)
Compile-tested: ar71xx, sunxi, mvebu, ramips/rt305x, lantiq
Runtime-tested: ar71xx, sunxi

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
17 files changed:
include/kernel-version.mk
target/linux/adm5120/patches-3.18/120-rb153_cf_driver.patch
target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch
target/linux/gemini/patches-3.18/150-gemini-pata.patch
target/linux/generic/patches-3.18/540-crypto-xz-decompression-support.patch
target/linux/generic/patches-3.18/701-phy_extension.patch
target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
target/linux/generic/patches-3.18/703-phy-add-detach-callback-to-struct-phy_driver.patch
target/linux/generic/patches-3.18/710-phy-add-mdio_register_board_info.patch
target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch
target/linux/imx6/patches-3.18/203-net-igb-add-phy-read-write-functions-that-accept-phy.patch
target/linux/imx6/patches-3.18/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
target/linux/lantiq/patches-3.18/0026-NET-multi-phy-support.patch
target/linux/oxnas/patches-3.18/250-add-plxtech-vendor-prefix.patch
target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
target/linux/ramips/patches-3.18/0033-NET-multi-phy-support.patch
target/linux/ramips/patches-3.18/0065-fix_dts_cache_issues.patch

index ee6f4da..9a95ef3 100644 (file)
@@ -2,9 +2,9 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .80
+LINUX_VERSION-3.18 = .84
 
-LINUX_KERNEL_MD5SUM-3.18.80 = 5f2bba0500b3650fdaa0bf6e06062056
+LINUX_KERNEL_MD5SUM-3.18.84 = e79685de43fcf3c4ada7d4fc5230a518
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index c5d4d3a..5390bd9 100644 (file)
@@ -10,7 +10,7 @@
  obj-$(CONFIG_PATA_SAMSUNG_CF) += pata_samsung_cf.o
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -955,6 +955,15 @@ config PATA_QDI
+@@ -958,6 +958,15 @@ config PATA_QDI
        help
          Support for QDI 6500 and 6580 PATA controllers on VESA local bus.
  
index 8da26fd..3476775 100644 (file)
                case IPV6_2292HOPOPTS:
 --- a/net/ipv6/ip6_gre.c
 +++ b/net/ipv6/ip6_gre.c
-@@ -479,11 +479,11 @@ static int ip6gre_rcv(struct sk_buff *sk
+@@ -482,11 +482,11 @@ static int ip6gre_rcv(struct sk_buff *sk
                        offset += 4;
                }
                if (flags&GRE_KEY) {
                        offset += 4;
                }
        }
-@@ -748,7 +748,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
+@@ -751,7 +751,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
  
                if (tunnel->parms.o_flags&GRE_SEQ) {
                        ++tunnel->o_seqno;
                        ptr--;
                }
                if (tunnel->parms.o_flags&GRE_KEY) {
-@@ -844,7 +844,7 @@ static inline int ip6gre_xmit_ipv6(struc
+@@ -847,7 +847,7 @@ static inline int ip6gre_xmit_ipv6(struc
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
index 62a71de..2fb2be0 100644 (file)
                .length         = SZ_512K,
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -536,6 +536,16 @@ config PATA_EP93XX
+@@ -539,6 +539,16 @@ config PATA_EP93XX
  
          If unsure, say N.
  
index 6b1721b..78d677d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -1438,6 +1438,13 @@ config CRYPTO_LZ4HC
+@@ -1437,6 +1437,13 @@ config CRYPTO_LZ4HC
        help
          This is the LZ4 high compression mode algorithm.
  
index fa4542b..5c63dbe 100644 (file)
@@ -53,7 +53,7 @@
   * @phydev: the phy_device struct
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -752,6 +752,7 @@ void phy_start_machine(struct phy_device
+@@ -748,6 +748,7 @@ void phy_start_machine(struct phy_device
  void phy_stop_machine(struct phy_device *phydev);
  int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
  int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);
index d20fc04..63040c0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -484,6 +484,12 @@ struct phy_driver {
+@@ -480,6 +480,12 @@ struct phy_driver {
        /* Determines the negotiated speed and duplex */
        int (*read_status)(struct phy_device *phydev);
  
index 061e40f..ca8e455 100644 (file)
@@ -12,7 +12,7 @@
  
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -502,6 +502,12 @@ struct phy_driver {
+@@ -498,6 +498,12 @@ struct phy_driver {
         */
        int (*did_interrupt)(struct phy_device *phydev);
  
index 424c63e..cc3cb24 100644 (file)
@@ -46,7 +46,7 @@
                phy_device_free(phydev);
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -789,4 +789,22 @@ int __init mdio_bus_init(void);
+@@ -785,4 +785,22 @@ int __init mdio_bus_init(void);
  void mdio_bus_exit(void);
  
  extern struct bus_type mdio_bus_type;
index 308eb9a..7cf9415 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -1520,3 +1520,6 @@ source "drivers/crypto/Kconfig"
+@@ -1519,3 +1519,6 @@ source "drivers/crypto/Kconfig"
  source crypto/asymmetric_keys/Kconfig
  
  endif # if CRYPTO
index 405d4ec..0feb878 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
 
 --- a/drivers/net/ethernet/intel/igb/e1000_82575.c
 +++ b/drivers/net/ethernet/intel/igb/e1000_82575.c
-@@ -2129,7 +2129,7 @@ static s32 igb_read_phy_reg_82580(struct
+@@ -2140,7 +2140,7 @@ static s32 igb_read_phy_reg_82580(struct
        if (ret_val)
                goto out;
  
@@ -25,7 +25,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  
        hw->phy.ops.release(hw);
  
-@@ -2154,7 +2154,7 @@ static s32 igb_write_phy_reg_82580(struc
+@@ -2165,7 +2165,7 @@ static s32 igb_write_phy_reg_82580(struc
        if (ret_val)
                goto out;
  
index 129a0bc..6ee3435 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
 
 --- a/drivers/net/ethernet/intel/igb/e1000_82575.c
 +++ b/drivers/net/ethernet/intel/igb/e1000_82575.c
-@@ -598,13 +598,25 @@ static s32 igb_get_invariants_82575(stru
+@@ -609,13 +609,25 @@ static s32 igb_get_invariants_82575(stru
        switch (link_mode) {
        case E1000_CTRL_EXT_LINK_MODE_1000BASE_KX:
                hw->phy.media_type = e1000_media_type_internal_serdes;
@@ -49,7 +49,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
                }
                /* fall through for I2C based SGMII */
        case E1000_CTRL_EXT_LINK_MODE_PCIE_SERDES:
-@@ -621,8 +633,11 @@ static s32 igb_get_invariants_82575(stru
+@@ -632,8 +644,11 @@ static s32 igb_get_invariants_82575(stru
                                hw->phy.media_type = e1000_media_type_copper;
                                dev_spec->sgmii_active = true;
                        }
@@ -259,7 +259,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
        /* start the watchdog. */
        hw->mac.get_link_status = 1;
        schedule_work(&adapter->watchdog_task);
-@@ -7111,21 +7249,41 @@ void igb_alloc_rx_buffers(struct igb_rin
+@@ -7113,21 +7251,41 @@ void igb_alloc_rx_buffers(struct igb_rin
  static int igb_mii_ioctl(struct net_device *netdev, struct ifreq *ifr, int cmd)
  {
        struct igb_adapter *adapter = netdev_priv(netdev);
index 5943602..3089710 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                }
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -364,6 +364,7 @@ struct phy_device {
+@@ -360,6 +360,7 @@ struct phy_device {
        bool is_c45;
        bool is_internal;
        bool has_fixups;
index 1645c88..b06d44f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Documentation/devicetree/bindings/vendor-prefixes.txt
 +++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
-@@ -115,6 +115,7 @@ panasonic  Panasonic Corporation
+@@ -116,6 +116,7 @@ panasonic  Panasonic Corporation
  phytec        PHYTEC Messtechnik GmbH
  picochip      Picochip Ltd
  plathome      Plat'Home Co., Ltd.
index af5e66f..6836904 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -401,6 +401,13 @@ config SATA_VITESSE
+@@ -404,6 +404,13 @@ config SATA_VITESSE
  
          If unsure, say N.
  
index f6d2456..8c62422 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                }
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -363,6 +363,7 @@ struct phy_device {
+@@ -359,6 +359,7 @@ struct phy_device {
        struct phy_c45_device_ids c45_ids;
        bool is_c45;
        bool is_internal;
index 520c570..a8ea480 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -675,7 +675,6 @@ static void __init arch_mem_init(char **
+@@ -679,7 +679,6 @@ static void __init arch_mem_init(char **
                                crashk_res.end - crashk_res.start + 1,
                                BOOTMEM_DEFAULT);
  #endif
@@ -8,7 +8,7 @@
        sparse_init();
        plat_swiotlb_setup();
        paging_init();
-@@ -784,6 +783,7 @@ void __init setup_arch(char **cmdline_p)
+@@ -788,6 +787,7 @@ void __init setup_arch(char **cmdline_p)
        prefill_possible_map();
  
        cpu_cache_init();