ramips: rt305x: add support for the ALFA Networks W502U (R36) board
authorGabor Juhos <juhosg@openwrt.org>
Wed, 28 Dec 2011 08:43:32 +0000 (08:43 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 28 Dec 2011 08:43:32 +0000 (08:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29615 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/leds
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w502u.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39

index 652787b..3cd5c0f 100755 (executable)
@@ -63,6 +63,9 @@ get_status_led() {
        v22rw-2x2)
                status_led="v22rw-2x2:green:security"
                ;;
+       w502u)
+               status_led="alfa:blue:wps"
+               ;;
        whr-g300n)
                status_led="whr-g300n:green:router"
                ;;
index 55c577e..47f7f01 100644 (file)
@@ -57,6 +57,7 @@ case "$FIRMWARE" in
        omni-emb | \
        rt-n15 | \
        v22rw-2x2 | \
+       w502u | \
        wcr-150gn | \
        whr-g300n | \
        wl-351 | \
index d0a9ac0..0877a1d 100755 (executable)
@@ -51,4 +51,8 @@ case $board in
        nw718)
                set_usb_led "nw718:amber:usb"
                ;;
+       w502u)
+               set_usb_led "alfa:blue:usb"
+               set_wifi_led "rt2800pci-phy0::radio"
+               ;;
 esac
index 834a2a7..f98162c 100755 (executable)
@@ -19,7 +19,8 @@ ramips_setup_interfaces()
        argus-atp52b | \
        b2c | \
        f5d8235-v2 | \
-       nw718)
+       nw718 | \
+       w502u)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ;;
 
@@ -86,6 +87,11 @@ ramips_setup_macs()
                 wan_mac=$(ramips_get_mac_binary factory 40)
                ;;
 
+       w502u)
+                lan_mac=$(ramips_get_mac_binary factory 40)
+                wan_mac=$(ramips_get_mac_binary factory 46)
+               ;;
+
        wli-tx4-ag300n)
                lan_mac=$(ramips_get_mac_binary factory 4)
                ;;
index eade567..f1d641c 100644 (file)
@@ -21,7 +21,8 @@ preinit_set_mac_address() {
                 ;;
        hw550-3g |\
        nbg-419n |\
-       omni-emb)
+       omni-emb |\
+       w502u)
                mac=$(ramips_get_mac_binary factory 40)
                ifconfig eth0 hw ether $mac 2>/dev/null
                ;;
index d197fce..f05fc3d 100755 (executable)
@@ -101,6 +101,9 @@ ramips_board_name() {
        *"V22RW-2X2")
                name="v22rw-2x2"
                ;;
+       *"W502U")
+               name="w502u"
+               ;;
        *"WHR-G300N")
                name="whr-g300n"
                ;;
index aebaf38..6d5d602 100755 (executable)
@@ -26,6 +26,7 @@ platform_check_image() {
        omni-emb | \
        rt-g32-b1 | \
        rt-n15 | \
+       w502u |\
        v22rw-2x2 | \
        wli-tx4-ag300n | \
        whr-g300n)
index 9e48b5c..df6adf4 100644 (file)
@@ -37,6 +37,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_OMNI_EMB,           /* Omnima MiniEMBWiFi */
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
+       RAMIPS_MACH_W502U,              /* ALFA Networks W502U */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
        RAMIPS_MACH_WHR_G300N,          /* Buffalo WHR-G300N */
        RAMIPS_MACH_WL351,              /* Sitecom WL-351 v1 002 */
index 3149af4..1bb67e2 100644 (file)
@@ -2,6 +2,11 @@ if RALINK_RT305X
 
 menu "Ralink RT350x machine selection"
 
+config RT305X_MACH_W502U
+       bool "ALFA Networks W502U board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_ARGUS_ATP52B
        bool "Argus ATP-52B support"
        select RALINK_DEV_GPIO_BUTTONS
index 2778f54..25d51fd 100644 (file)
@@ -25,6 +25,7 @@ obj-$(CONFIG_RT305X_MACH_OMNI_EMB)    += mach-omni-emb.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
+obj-$(CONFIG_RT305X_MACH_W502U)                += mach-w502u.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
 obj-$(CONFIG_RT305X_MACH_WR512_3GN)    += mach-wr512-3gn.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w502u.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w502u.c
new file mode 100644 (file)
index 0000000..2c9cd44
--- /dev/null
@@ -0,0 +1,129 @@
+/*
+ *  ALFA Networks W502U board support
+ *
+ *  Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define W502U_GPIO_LED_USB             13
+#define W502U_GPIO_LED_WPS             14
+
+#define W502U_GPIO_BUTTON_WPS          0
+#define W502U_GPIO_BUTTON_RESET                10
+
+#define W502U_BUTTONS_POLL_INTERVAL    20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition w502u_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "config",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0d0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x120000,
+               .size   = 0x6d0000,
+       }, {
+               .name   = "data3g",
+               .offset = 0x7f0000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "firmware",
+               .offset = 0x050000,
+               .size   = 0x7a0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data w502u_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(w502u_partitions),
+       .parts          = w502u_partitions,
+#endif
+};
+
+static struct gpio_led w502u_leds_gpio[] __initdata = {
+       {
+               .name           = "alfa:blue:usb",
+               .gpio           = W502U_GPIO_LED_USB,
+               .active_low     = 1,
+       },
+       {
+               .name           = "alfa:blue:wps",
+               .gpio           = W502U_GPIO_LED_WPS,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_button w502u_gpio_buttons[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = W502U_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = W502U_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       },
+};
+
+static void __init w502u_init(void)
+{
+       rt305x_gpio_init((RT305X_GPIO_MODE_GPIO <<
+                         RT305X_GPIO_MODE_UART0_SHIFT));
+
+       rt305x_register_flash(0, &w502u_flash_data);
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(w502u_leds_gpio),
+                                 w502u_leds_gpio);
+       ramips_register_gpio_buttons(-1, W502U_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(w502u_gpio_buttons),
+                                    w502u_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_W502U, "W502U", "ALFA Networks W502U",
+             w502u_init);
index a2845fd..b661cab 100644 (file)
@@ -123,8 +123,10 @@ define Image/Build/Template/GENERIC_4M
 endef
 
 mtdlayout_8M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
+kernel_size_8M=851968
+rootfs_size_8M=7208960
 define Image/Build/Template/GENERIC_8M
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_8M,851968,7208960)
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_8M,$(kernel_size_8M),$(rootfs_size_8M))
 endef
 
 mtdlayout_dir300b1=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
@@ -228,6 +230,10 @@ define Image/Build/Profile/WCR150GN
        $(call Image/Build/Template/GENERIC_4M,$(1),wcr150gn,WCR150GN)
 endef
 
+w502u_cmdline=board=W502U console=ttyS1,115200
+define Image/Build/Profile/W502U
+       $(call BuildFirmware/Generic,$(1),w502u,$(w502u_cmdline),mtdlayout_8M,$(kernel_size_8M),$(rootfs_size_8M))
+endef
 
 mtdlayout_argus_atp52b=mtdparts=physmap-flash.0:192k(bootloader)ro,64k(config),64k(factory),1152k(kernel),6656k(rootfs),7808k@0x50000(firmware)
 mtd_argus_atp52b_kernel_part_size=1179648
@@ -278,6 +284,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
+       $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WR5123GN,$(1))
        $(call Image/Build/Profile/WL351,$(1))
 endef
index 68d9a23..3f67bc5 100644 (file)
@@ -105,6 +105,7 @@ CONFIG_RT305X_MACH_OMNI_EMB=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
+CONFIG_RT305X_MACH_W502U=y
 CONFIG_RT305X_MACH_WCR150GN=y
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_RT305X_MACH_WL351=y