tools: fix stat symlink if destination already exists
authorFelix Fietkau <nbd@openwrt.org>
Mon, 26 Mar 2012 10:07:50 +0000 (10:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 26 Mar 2012 10:07:50 +0000 (10:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31072 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile

index 48cfbbc..87a2940 100644 (file)
@@ -102,6 +102,7 @@ endef
 endif
 
 $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
+       @rm -f $@
        @if stat --version > /dev/null 2>&1; then \
                ln -s `which stat` $@; \
        elif gstat --version > /dev/null 2>&1; then \