CC: procd: align early init PATH with rest of OpenWrt
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 14 Jan 2016 13:06:36 +0000 (13:06 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 14 Jan 2016 13:06:36 +0000 (13:06 +0000)
Backport upstream Git commit 45cb04fd85d788a37367a5385e5e90dd98a0a991 to CC.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48236 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/procd/Makefile
package/system/procd/patches/0001-Align-early-init-PATH-with-system-wide-OpenWrt-path.patch [new file with mode: 0644]

index badd3e4..d343f74 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014-2015 OpenWrt.org
+# Copyright (C) 2014-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2015-10-29
+PKG_VERSION:=2015-10-29.1
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
diff --git a/package/system/procd/patches/0001-Align-early-init-PATH-with-system-wide-OpenWrt-path.patch b/package/system/procd/patches/0001-Align-early-init-PATH-with-system-wide-OpenWrt-path.patch
new file mode 100644 (file)
index 0000000..c8072ea
--- /dev/null
@@ -0,0 +1,32 @@
+From 45cb04fd85d788a37367a5385e5e90dd98a0a991 Mon Sep 17 00:00:00 2001
+From: Jo-Philipp Wich <jow@openwrt.org>
+Date: Thu, 14 Jan 2016 13:51:36 +0100
+Subject: [PATCH] Align early init PATH with system wide OpenWrt path value
+
+Changeset r47080 globally unified the executable search path in OpenWrt,
+now update procd to use the same path value.
+
+This fixes diverging path values observed in programs launched by netifd
+which inherits the early path value from procd.
+
+Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
+---
+ initd/early.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/initd/early.c b/initd/early.c
+index e87774f..5821c58 100644
+--- a/initd/early.c
++++ b/initd/early.c
+@@ -90,7 +90,7 @@ early_mounts(void)
+ static void
+ early_env(void)
+ {
+-      setenv("PATH", "/bin:/sbin:/usr/bin:/usr/sbin", 1);
++      setenv("PATH", "/usr/sbin:/usr/bin:/sbin:/bin", 1);
+ }
+ void
+-- 
+2.1.4
+