package: fix insmod on install
authorJohn Crispin <blogic@openwrt.org>
Sat, 22 Jun 2013 22:09:40 +0000 (22:09 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sat, 22 Jun 2013 22:09:40 +0000 (22:09 +0000)
the procd changes broke the postinst insmod.

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37015 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk
package/base-files/files/lib/functions.sh

index b637de5..cbf342a 100644 (file)
@@ -105,7 +105,7 @@ define ModuleAutoLoad
                echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
                echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
                echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst; \
-               echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
+               echo "insert_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
                chmod 0755 $(2)/CONTROL/postinst; \
        fi
 endef
index 42d76fd..bc521b0 100755 (executable)
@@ -203,6 +203,13 @@ config_list_foreach() {
        done
 }
 
+insert_modules() {
+       [ -d /etc/modules.d ] && {
+               cd /etc/modules.d
+               sed 's/^[^#]/insmod &/' $* | ash 2>&- || :
+       }
+}
+
 include() {
        local file